Results 1 to 10 of 10

Thread: Heated Gear

  1. #1
    Very Active Member
    Join Date
    Oct 2016
    Location
    Lakeland, FL
    Posts
    830
    Spyder Garage
    0

    Default Heated Gear

    OK, I have my 2020 RTL now, so I'm thinking, how do I do a s.a.e plug for the heated vest? On the old Honda trike I Just ran a wire off the battery, quite simple. Rather not do that with the new Spyder, bad things would probably happen. I may not need a heated vest, but what if?

  2. #2
    Active Member
    Join Date
    Jun 2016
    Location
    indpls in
    Posts
    360
    Spyder Garage
    0

    Default

    nothing will happen all is good

  3. #3
    Member
    Join Date
    Jul 2020
    Location
    Decatur, IL
    Posts
    8
    Spyder Garage
    0

    Default

    Quote Originally Posted by bikerbillone View Post
    OK, I have my 2020 RTL now, so I'm thinking, how do I do a s.a.e plug for the heated vest? On the old Honda trike I Just ran a wire off the battery, quite simple. Rather not do that with the new Spyder, bad things would probably happen. I may not need a heated vest, but what if?
    Not sure why you would think BAD things would happen. I just wired mine yesterday and not a problem. I did a little research and it looks like the 1330 engine output on the alternator is 1200watts . This should be plenty to run a jacket liner or vest etc. How can I help you with your issue

  4. #4
    Very Active Member Mikey's Avatar
    Join Date
    Sep 2017
    Location
    Durham,Maine
    Posts
    1,043
    Spyder Garage
    1

    Default

    Any thing you have done in the past will most likely work on this bike also!! Go for it!!

  5. #5
    Very Active Member pegasus1300's Avatar
    Join Date
    Feb 2012
    Location
    Spring City,Utah
    Posts
    3,672
    Spyder Garage
    1

    Default

    Bill just run your wires straight off the battery as befor on the GW. Since you are coming from the battery to the vest direct there is no problem.

    Happy TRAils/NSD
    Paul

    2012 RT L
    AMA
    TRA
    PGR
    Rhino Riders Plate #83
    Venturers #78
    Venture Riders
    TOI

  6. #6
    Very Active Member
    Join Date
    Oct 2016
    Location
    Lakeland, FL
    Posts
    830
    Spyder Garage
    0

    Default

    Thanks much for all the confidence, I will run the wires. Read some comments on SL, or somewhere, use caution with wiring on the Syder, so I'm good to go with the comments here.

  7. #7
    Very Active Member pegasus1300's Avatar
    Join Date
    Feb 2012
    Location
    Spring City,Utah
    Posts
    3,672
    Spyder Garage
    1

    Default

    That is when tying into the canbuss system. You are not doing that. Not tying into the wiring at all.

    Happy TRAils/NSD
    Paul

    2012 RT L
    AMA
    TRA
    PGR
    Rhino Riders Plate #83
    Venturers #78
    Venture Riders
    TOI

  8. #8
    Very Active Member samewok's Avatar
    Join Date
    Oct 2011
    Location
    Jacksonville,Ar
    Posts
    1,170
    Spyder Garage
    1

    Default

    Yes I have mine connected to the battery for heated gear and trickle charge
    4" Stubby antenna, Dual arm LEDs Fender LEDs, Back Rest, Luggage Rack, Run, Brake and Strobe for top case, Mirror LEDs,Back Off decal on mud flap, reciptal for Battery Tender and Heated Gear, mirror LEDs that stay on or work with blinkers, GPS, side bag red LEDs, Top cuff with Ram Ball phone holder And USB power, Top cuff with drink holder and passenger cup holder. Also grilles in front of radiators, also spyclops. Garmin 595 GPS, Freedom windshield.

  9. #9
    Very Active Member trikermutha's Avatar
    Join Date
    Sep 2014
    Location
    USA
    Posts
    3,693
    Spyder Garage
    0

    Default

    I ran the wires from my battery to the controller and put heat knobs on top of the dash and for the passenger on the left handle rail area.

    So everything is under the plastic except for the controller knobs and small lights.

  10. #10
    Very Active Member Mikey's Avatar
    Join Date
    Sep 2017
    Location
    Durham,Maine
    Posts
    1,043
    Spyder Garage
    1

    Default

    Just make sure you put a fuse in line with it at the correct amps, you'll be ok!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •