Results 1 to 11 of 11
  1. #1
    Active Member viperryder's Avatar
    Join Date
    Oct 2011
    Location
    Ohio
    Posts
    337
    Spyder Garage
    1

    Default 2014 RTS SE6 Won't start?

    Problem with 2014 RTS SE6. Won't start. When key is turned on screen goes right start screen. Turn key and no click. Took battery to Bull Dog battery to have load tested and they stated well beyond good. Checked main fuse for motor and can't tell if okay. Any ideas to help?????
    2011 RT-S SE5 Viper Red
    2014 RT-S SE6 Cognac
    Bajaron sway bar w/ aluminum heims
    Custom Design HM Brake light
    Custom Design Red front fender lights with turn signals
    Lidlox
    Corbin arm rests

  2. #2
    Very Active Member CopperSpyder's Avatar
    Join Date
    Nov 2018
    Location
    Waynesboro, PA
    Posts
    2,306
    Spyder Garage
    1

    Default

    Ok basic stuff. Turn key, hit mode button make sure kill switch is off (click switch back and forth a few time to make sure) Step on brake and keep foot on brake hard now push start button.
    My Spyder

  3. #3
    Very Active Member Mikey's Avatar
    Join Date
    Sep 2017
    Location
    Durham,Maine
    Posts
    1,432
    Spyder Garage
    1

    Default


  4. #4
    Very Active Member billybovine's Avatar
    Join Date
    Jul 2011
    Location
    Mitchell, Ontario, Canada
    Posts
    6,062
    Spyder Garage
    0

    Default

    After the battery has been disconnected and hooked back up again. The press mode button step is skipped the first time. That is normal. So ignore that symptom.

    Follow the basics as CopperSpyder said.

    2018 F3 LIMITED

  5. #5
    Active Member viperryder's Avatar
    Join Date
    Oct 2011
    Location
    Ohio
    Posts
    337
    Spyder Garage
    1

    Default

    Sometimes we just miss the obvious. I never use the kill switch, therefore I did not think to check it. A big thanks to CopperSpyder for his suggestion. As many people have stated in the past "THIS WEBSITE IR GREAT!!!!!!!!!!!!!' Again THANKS
    2011 RT-S SE5 Viper Red
    2014 RT-S SE6 Cognac
    Bajaron sway bar w/ aluminum heims
    Custom Design HM Brake light
    Custom Design Red front fender lights with turn signals
    Lidlox
    Corbin arm rests

  6. #6
    Active Member
    Join Date
    Apr 2016
    Location
    Bloomington, Minnesota
    Posts
    260
    Spyder Garage
    0

    Default

    I've hit both/either the kill switch or the 4-way flash on dismount and didn't catch it. So when I rode again, the battery was dead, and even then it wouldn't start. We-ve been there!.

  7. #7
    Very Active Member Mikey's Avatar
    Join Date
    Sep 2017
    Location
    Durham,Maine
    Posts
    1,432
    Spyder Garage
    1

    Default

    Quote Originally Posted by viperryder View Post
    Sometimes we just miss the obvious. I never use the kill switch, therefore I did not think to check it. A big thanks to CopperSpyder for his suggestion. As many people have stated in the past "THIS WEBSITE IR GREAT!!!!!!!!!!!!!' Again THANKS
    You owned it!!!!

  8. #8
    Active Member
    Join Date
    Sep 2018
    Location
    Florida / NC
    Posts
    39
    Spyder Garage
    0

    Default

    Rode mine a couple of days ago for about 90 miles. Went out today and absolutely nothing. Seems I had parked the car a little closer and the spare key was in the car, was thinking I would have to haul it somewhere. Key has been moved.

  9. #9
    Very Active Member billybovine's Avatar
    Join Date
    Jul 2011
    Location
    Mitchell, Ontario, Canada
    Posts
    6,062
    Spyder Garage
    0

    Default

    Quote Originally Posted by gg194 View Post
    Rode mine a couple of days ago for about 90 miles. Went out today and absolutely nothing. Seems I had parked the car a little closer and the spare key was in the car, was thinking I would have to haul it somewhere. Key has been moved.
    The spare key in the car has nothing to do with it. The chip in the key has a range of only an inch or two.

    2018 F3 LIMITED

  10. #10
    Active Member
    Join Date
    Aug 2019
    Location
    soutwest oHIo
    Posts
    259
    Spyder Garage
    0

    Default

    Quote Originally Posted by gg194 View Post
    Rode mine a couple of days ago for about 90 miles. Went out today and absolutely nothing. Seems I had parked the car a little closer and the spare key was in the car, was thinking I would have to haul it somewhere. Key has been moved.
    Why would the spare key in the car have anything to do with the Spyder battery going dead?

    If it's because having a key close to the Spyder does 'something', then we have a problem with ours.

    Just can't get much closer than being parked in the garage with the key in the ignition.

    .
    HER rides:
    2017 RT-S SE6 Pearl White
    1982 Suzuki GS850GL

    My rides:
    2000 Honda GL1500SE
    1980 Suzuki GS850G

  11. #11
    Very Active Member
    Join Date
    Aug 2008
    Location
    Maryland
    Posts
    1,070
    Spyder Garage
    0

    Default

    Same - I have the IPS key holder from Lamonster garage - and it stays in the ignition all the time - well almost all the time - - No issues whatsoever - I used on three different models of Spyder's (RS/F3/RT).
    2020 RT Ride Frequent Stay Safe
    2008 RS from 2008 through 4/2015, 2015 F3-S from 4/2015 through 9/2020

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •