Results 1 to 8 of 8
  1. #1
    Active Member Richardv's Avatar
    Join Date
    Oct 2014
    Location
    Montreal north shore, QC
    Posts
    204
    Spyder Garage
    0

    Default Bayaron oil catch can......

    Hi,

    Here is a picture of my Bayaron catch can after 470km (300miles). We can clearly see that it does the job. And this is with the oil level set on the full mark.

    RichardIMG_1387.jpgIMG_1397.jpg
    Attached Images Attached Images



    Richard

    * 2012 RS SE5 (hers)
    * 2013 ST SM5 (mine)

    Daughter RSS SE5 2014
    Son in law RSS SM5 2013

    P.S. 3 Kumho AST 225/50R15 and 1 Toyo Proxies 4 225/50R15 rear tires
    3 sets of Kumho 175/55R15 front tires....
    1 set of Canadian Tire General tire Evertrek RTX in 14" for the 2012 ...

  2. #2
    Very Active Member Chupaca's Avatar
    Join Date
    Oct 2012
    Location
    San Diego, CA.
    Posts
    30,919
    Spyder Garage
    1

    Default Nice

    Have seen some home made ones but it is nice to see a bolt on kit available...thanks and congrats...
    Gene and Ilana De Laney
    Mt. Helix, California

    ​2012 RS sm5

  3. #3
    Active Member Richardv's Avatar
    Join Date
    Oct 2014
    Location
    Montreal north shore, QC
    Posts
    204
    Spyder Garage
    0

    Default For the record...

    Quote Originally Posted by Chupaca View Post
    Have seen some home made ones but it is nice to see a bolt on kit available...thanks and congrats...
    Yap. You have the filter part # and I used 1/2" heater hose. There is no place for any nipples, so I just slipped the hoses on the filter itself.

    Richard



    Richard

    * 2012 RS SE5 (hers)
    * 2013 ST SM5 (mine)

    Daughter RSS SE5 2014
    Son in law RSS SM5 2013

    P.S. 3 Kumho AST 225/50R15 and 1 Toyo Proxies 4 225/50R15 rear tires
    3 sets of Kumho 175/55R15 front tires....
    1 set of Canadian Tire General tire Evertrek RTX in 14" for the 2012 ...

  4. #4
    SpyderLovers Sponsor BajaRon's Avatar
    Join Date
    Aug 2007
    Location
    Greeneville, TN
    Posts
    10,628
    Spyder Garage
    0

    Default

    I've always been partial to this one for some reason!

    Glad it's working for you!
    Only SLOW people have to leave on time...





  5. #5
    Very Active Member
    Join Date
    Dec 2015
    Location
    Oakley, Utah & Yuma, Arizona
    Posts
    5,456
    Spyder Garage
    2

    Default

    Quote Originally Posted by BajaRon View Post
    I've always been partial to this one for some reason! Glad it's working for you!
    Ron, is this problem and solution unique to the 998 engine?

    2014 RTL Platinum & 2014 RTL Cognac
    Northern Utah in summer; Yuma, AZ in winter.

  6. #6
    SpyderLovers Sponsor BajaRon's Avatar
    Join Date
    Aug 2007
    Location
    Greeneville, TN
    Posts
    10,628
    Spyder Garage
    0

    Default

    Quote Originally Posted by UtahPete View Post
    Ron, is this problem and solution unique to the 998 engine?
    I believe it is unique to the 998. I have not heard anyone complaining about the 1330 having this issue.
    Only SLOW people have to leave on time...





  7. #7
    Member
    Join Date
    Mar 2018
    Location
    south africa
    Posts
    13
    Spyder Garage
    0

    Default

    hi ron your email pls want to send pic of one just made and get your comment , cannot upload pic to thread, ddtoit@amplats.co.za

  8. #8
    SpyderLovers Sponsor BajaRon's Avatar
    Join Date
    Aug 2007
    Location
    Greeneville, TN
    Posts
    10,628
    Spyder Garage
    0

    Default

    Quote Originally Posted by ddtoit View Post
    hi ron your email pls want to send pic of one just made and get your comment , cannot upload pic to thread, ddtoit@amplats.co.za
    Email sent...
    Only SLOW people have to leave on time...





Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •