Results 1 to 17 of 17
  1. #1
    Active Member
    Join Date
    Oct 2021
    Location
    Texas
    Posts
    40
    Spyder Garage
    0

    Default Ryker mph/rpm/reverse

    Hello everyone,
    Can someone help me out.
    My mph, rpm just froze and wonít function properly and I noticed the beeping when I put it in reverse also stopped.

    Iím disconnecting the battery for a while to see if that helps.

    Thank you,

    Gerome D

  2. #2
    Active Member
    Join Date
    Oct 2021
    Location
    Texas
    Posts
    40
    Spyder Garage
    0

    Default Ryker mph/rpm/reverse just froze & won't work - any ideas?

    Hello everyone,
    Can someone help me out.
    My mph, rpm just froze and wonít function properly and I noticed the beeping when I put it in reverse also stopped.

    Iím disconnecting the battery for a while to see if that helps.

    Thank you,

    Gerome D

  3. #3
    Ozzie Ozzie Ozzie Peter Aawen's Avatar
    Join Date
    Dec 2013
    Location
    Australia; Sth Aust, Adelaide Hills
    Posts
    6,848
    Spyder Garage
    0

    Default

    Gerome, I've merged your 2 threads - no point in having more than 1 & expanded your title to briefly ask your question... usually works better at getting answers.

    That's an odd one on a Ryker!! I'm not all that sure that disconnecting the battery will do anything, but it certainly can't hurt...

    Maybe while it's disconnected you could test its voltage (tell us what it says ) &/or attach a charger just to make sure that the dash/reverse beep freezing thing isn't just a sign of a flat battery?!?

    Over to you!
    Last edited by Peter Aawen; 06-22-2022 at 06:07 PM.
    2013 RT Ltd Pearl White

    Ryde More, Worry Less!

  4. #4
    Very Active Member
    Join Date
    Dec 2015
    Location
    Northern Utah in summer & SW Arizona in winter
    Posts
    7,105
    Spyder Garage
    0

    Default

    Quote Originally Posted by JaxBella View Post
    Hello everyone, Can someone help me out.
    My mph, rpm just froze and won’t function properly and I noticed the beeping when I put it in reverse also stopped.
    I’m disconnecting the battery for a while to see if that helps.
    Thank you, Gerome D
    You mean the gauges froze at one reading? The reverse works but doesn't give warning beep?

    Can you provide more of an explanation?
    Last edited by UtahPete; 06-22-2022 at 08:41 PM.
    2014 RTL Platinum & 2014 RTL Cognac


  5. #5
    Active Member
    Join Date
    Oct 2021
    Location
    Texas
    Posts
    40
    Spyder Garage
    0

    Default

    Hi there
    Thank you for responding

    I currently don’t have any response when pushing the soft buttons on the instrument cluster.
    There is no mph, rpm, or temp reading
    I can’t get out of eco mode since I have no response when pushing the soft buttons on the cluster panel

    When I put the bike in reverse there is no more beeping sound, hazards than normally would come don’t anymore.

    Signals don’t come off automatically when making a turn, I have to turn it off manually.

    I appreciate everyone’s input.

  6. #6
    Very Active Member
    Join Date
    Dec 2015
    Location
    Northern Utah in summer & SW Arizona in winter
    Posts
    7,105
    Spyder Garage
    0

    Default

    What model and year is your Ryker?
    2014 RTL Platinum & 2014 RTL Cognac


  7. #7
    Active Member
    Join Date
    Oct 2021
    Location
    Texas
    Posts
    40
    Spyder Garage
    0

    Default

    2020 Ryker 900ace

  8. #8
    Very Active Member EdMat's Avatar
    Join Date
    Apr 2019
    Location
    Clinton, MS
    Posts
    969
    Spyder Garage
    1

    Default

    I guess that disconnecting the battery made no change?
    2019 RT Limited , Phoenix Orange

  9. #9
    Very Active Member Mikey's Avatar
    Join Date
    Sep 2017
    Location
    Durham,Maine
    Posts
    2,612
    Spyder Garage
    1

    Default

    Are you getting a blank screen nothing on it at all? Maybe it came unhooked in the rear, or it's shot all together! Still under warranty, use it!!
    2012 RTL , Pearl

  10. #10
    Very Active Member
    Join Date
    Dec 2015
    Location
    Northern Utah in summer & SW Arizona in winter
    Posts
    7,105
    Spyder Garage
    0

    Default

    Quote Originally Posted by EdMat View Post
    I guess that disconnecting the battery made no change?
    I think Ed is suggesting disconnecting and reconnecting the battery as a start to helping you troubleshoot the problem. Most of us are familiar with Spyders, but not Rykers. However some troubleshooting may be common to both.

    This is the first I knew of a beeping alarm when a Ryker is in Reverse.
    2014 RTL Platinum & 2014 RTL Cognac


  11. #11
    Active Member
    Join Date
    Oct 2021
    Location
    Texas
    Posts
    40
    Spyder Garage
    0

    Default

    Quote Originally Posted by UtahPete View Post
    I think Ed is suggesting disconnecting and reconnecting the battery as a start to helping you troubleshoot the problem. Most of us are familiar with Spyders, but not Rykers. However some troubleshooting may be common to both.

    This is the first I knew of a beeping alarm when a Ryker is in Reverse.
    The screen is on but not functioning
    Nothing works it just at 0 and the temp gauge has 0 bars
    The buttons on the side I canít even use it doesnít work

    When I used to put it in reverse it a beeping ďwarningĒ sound to alert people around you

  12. #12
    Active Member
    Join Date
    Oct 2021
    Location
    Texas
    Posts
    40
    Spyder Garage
    0

    Default

    I disconnected the battery overnight and still the same issue

  13. #13
    Very Active Member
    Join Date
    Dec 2015
    Location
    Northern Utah in summer & SW Arizona in winter
    Posts
    7,105
    Spyder Garage
    0

    Default

    Quote Originally Posted by JaxBella View Post
    The screen is on but not functioning
    Nothing works it just at 0 and the temp gauge has 0 bars
    The buttons on the side I can’t even use it doesn’t work

    When I used to put it in reverse it a beeping “warning” sound to alert people around you
    It sure does seem like there's a problem with the electronic module that controls those things. Take it to the dealer while it's still under warranty.
    2014 RTL Platinum & 2014 RTL Cognac


  14. #14
    Active Member sKiZo's Avatar
    Join Date
    Mar 2021
    Location
    Michigan
    Posts
    239
    Spyder Garage
    0

    Default

    Wondering if you were fiddling about with something around the dash module and knocked something loose? Maybe driving in the rain with a loose connector?

    And ya, sounds like there may be a service visit in you future, eh.
    Half a million miles, and I ain't dead yet.

    See my album at https://www.spyderlovers.com/forums/...p?albumid=5190

  15. #15
    Active Member
    Join Date
    Oct 2021
    Location
    Texas
    Posts
    40
    Spyder Garage
    0

    Default

    Where is the dash module located ?

    Yes I’m dreading the service visit everywhere is backed up!

  16. #16
    Ozzie Ozzie Ozzie Peter Aawen's Avatar
    Join Date
    Dec 2013
    Location
    Australia; Sth Aust, Adelaide Hills
    Posts
    6,848
    Spyder Garage
    0

    Default

    Quote Originally Posted by JaxBella View Post
    Where is the dash module located ?

    Yes I’m dreading the service visit everywhere is backed up!
    Look for the bit where the speedo, tacho, gas gauge, etc normally appear, with the buttons on it. That's the dash module - it's the black box that makes up the dash & all its workings, display, buttons etc...There's a fairly large bunch of wires that plug into it - check to make sure that's tight, not wet, etc.
    Last edited by Peter Aawen; 06-24-2022 at 12:24 PM.
    2013 RT Ltd Pearl White

    Ryde More, Worry Less!

  17. #17
    Active Member
    Join Date
    Oct 2021
    Location
    Texas
    Posts
    40
    Spyder Garage
    0

    Default

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •