Results 1 to 11 of 11
  1. #1
    Member
    Join Date
    Mar 2022
    Location
    Mio, Michigan
    Posts
    8
    Spyder Garage
    1

    Default Blown headlight, replaced & working, then blew again! Any ideas??

    2012 RSS. Just bought it and the right headlight was not working. Replaced with Sylvania H7 C1. Started up to check, both lights worked. Reved a couple times, heard a pop and right light blew, again. Any idea what I should be looking for?
    2008 Kawasaki KLR-650
    2012 RSS , Green/black

  2. #2
    Ozzie Ozzie Ozzie Peter Aawen's Avatar
    Join Date
    Dec 2013
    Location
    Australia; Sth Aust, Adelaide Hills
    Posts
    6,835
    Spyder Garage
    0

    Default

    If you ever need to replace one headlight out of a pair, you should always replace both or you risk stressing one or both of the globes.... altho it usually means you'll just blow the older globe fairly soon!

    However, given that you just put in one new globe & it blew almost straight away, off the top of my head, there's probably only 4 'most likely' possibilities -

    1. That new globe wasn't ever going to last long due to some manufacturing defect;
    2. You somehow touched the glass of the new globe with a bare finger &/or skin during the installation procedure, compromising that globe so it blew once it got hot enough;
    3. That new globe isn't a match for the remaining globe in type/wattage & it's the lighter/weaker unit, so it blew pretty much when first used & over stressed by the current trying to match that being run thru the other globe; or
    4. The original globe in that light blew for some reason other than a globe failure - ie. a wiring issue or short somewhere that you didn't detect & correct before replacing the globe, so it's not the globes fault at all - there's something else wrong in that circuit!

    Just some quick thoughts - Help any?!
    Last edited by Peter Aawen; 06-18-2022 at 05:55 PM.
    2013 RT Ltd Pearl White

    Ryde More, Worry Less!

  3. #3
    Member
    Join Date
    Nov 2017
    Location
    Florida
    Posts
    5
    Spyder Garage
    0

    Default

    Had the same problem blowing bulbs. Water got into the headlight housing (both sides) and corrision set in. The dealer wouldn't cover it under warranty because I didn't use BRP bulbs. Just another loophole to screw us out of money...
    Last edited by Peter Aawen; 06-19-2022 at 07:14 PM. Reason: Changed ,'s to 's ;-)

  4. #4
    Very Active Member BLUEKNIGHT911's Avatar
    Join Date
    Aug 2011
    Location
    Central VERMONT
    Posts
    17,831
    Spyder Garage
    0

    Default

    Quote Originally Posted by jcastiglia View Post
    Had the same problem blowing bulbs. Water got into the headlight housing (both sides) and corrision set in. The dealer wouldn't cover it under warranty because I didn't use BRP bulbs. Just another loophole to screw us out of money...
    " didn't use BRP bulbs " total HOOEY ..... the warranty should be on housing .... not for the actual Bulbs !!!!! ...... JMHO .... Mike
    Last edited by Peter Aawen; 06-19-2022 at 07:15 PM. Reason: Fixed quote display

  5. #5
    Active Member cravenfun's Avatar
    Join Date
    Oct 2021
    Location
    Montague, NJ
    Posts
    60
    Spyder Garage
    1

    Default

    I always clean bulbs with alcohol, new or used, before putting them back in. Who knows what happened at the bulb plant with a new one.
    John
    "some suffer from insanity, I choose to enjoy it"
    '15 F3S SE6
    '01 FLHR
    Ski Doo 1200's
    Boats
    2015 F3S SE6 , Magnesium

  6. #6
    Very Active Member IdahoMtnSpyder's Avatar
    Join Date
    Jan 2014
    Location
    Idaho
    Posts
    8,969
    Spyder Garage
    1

    Default

    Quote Originally Posted by jcastiglia View Post
    Had the same problem blowing bulbs. Water got into the headlight housing (both sides) and corrision set in. The dealer wouldn't cover it under warranty because I didn't use BRP bulbs. Just another loophole to screw us out of money...
    BRP doesn't make bulbs. They buy them from whatever supplier they get the best deal from.

    2014 Copper RTS

    Tri-Axis bars, CB, BajaRon sway bar & shock adjusters, SpyderPop's Bumpskid, NBV peg brackets, LED headlights and modulator, Wolo trumpet air horns, trailer hitch, custom trailer harness, high mount turn signals, Custom Dynamics brake light, LED turn signal lights on mirrors, LED strip light for a dash light, garage door opener, LED lights in frunk, trunk, and saddlebags, RAM mounts and cradles for tablet (for GPS) and phone (for music), and Smooth Spyder belt tensioner.
    2014 RTS , Copper! (officially Cognac)

  7. #7
    Active Member
    Join Date
    Aug 2017
    Location
    New York
    Posts
    47
    Spyder Garage
    0

    Default

    I wonder if battery, connections, and alternator are good? I would think maybe a spike in voltage occurred to pop the new bulb. MikeL.
    Last edited by Peter Aawen; 06-20-2022 at 06:30 PM. Reason: ' 's ;-)

  8. #8
    Member
    Join Date
    Mar 2022
    Location
    Mio, Michigan
    Posts
    8
    Spyder Garage
    1

    Default

    I know how y’all like updates, so here we go. My right bulb blew because I tore a hole in my latex glove, didn’t know it and apparently touched the bulb. So went and got another. Me and my assistant got into a discussion on what size bulb I needed. I thought it was an H2 for some reason. He thought he saw on line it was an H3. The one I had was an H7. I found nothing in any books that said, so with the confusion, we decided to pull the left bulb to make sure they were the same. Big mistake. After fighting to get the left bulb back in for what seemed like hours, it now flickers. Guess I just keep plugging at it and see what I come up with.
    2008 Kawasaki KLR-650
    2012 RSS , Green/black

  9. #9
    Very Active Member Snowbelt Spyder's Avatar
    Join Date
    Nov 2015
    Location
    Chardon, OH
    Posts
    1,041
    Spyder Garage
    0

    Default

    Mark. Did some snooping around and I believe you were correct in the beginning. It’s an H7, 55W Halogen. Can’t help with why the left one is giving you fits. Maybe it’s not the correct bulb. Why not just get a 2 pack and replace them both while you have the thing all apart already?


    Doug

    2012 Spyder RT LTD Lava Bronze, RT 622, Original Owner, BUDS Megatech License

    ”Freedom is not a loophole”

    Seal Pups, F4 Customs SWCV, Corbin, JT's Air Filter, Cat Bypass, Power Commander V, NBV, SpyderFlap, Rivco Dual Flag Holder, Lidlox, Baja Ron Sway Bar, links, plugs and wires, Adjustable Chrome Side Vents, Spyderpops Block Off Plate and Belt Guard, Bump Skid, Canisterectomy, Akrapovic, TricLed HL/FL and Mag Mirrors, Spyder Cuff with X-Grip, S-Drive, Quatrac 5, Rock Armour, P238, Smoothspyder, Laser Alignment by Gray Ghost, Windshield Arm by Noboot.

  10. #10
    Member
    Join Date
    Mar 2022
    Location
    Mio, Michigan
    Posts
    8
    Spyder Garage
    1

    Default

    Another update. Monday in frustration I just walked away from my gremlins, figured the break would do me good. So, I go out Tuesday, both are working. Go figure. Button it back up, go for ride down very bumpy road, both still working when I get back. Feeling rather proud of myself right about now. Yesterday I go out and the right is working, left not. Go out today and have nothing again. I know I need to check wiring but how can I get to it? Is there a way to get the fairing around the cluster off? They got it on, gotta be a way to get it back off.
    Last edited by Peter Aawen; 06-23-2022 at 07:44 PM. Reason: brake (as in 'stopping') - break
    2008 Kawasaki KLR-650
    2012 RSS , Green/black

  11. #11
    Very Active Member Snowbelt Spyder's Avatar
    Join Date
    Nov 2015
    Location
    Chardon, OH
    Posts
    1,041
    Spyder Garage
    0

    Default

    Yo Mark. Why don't you just buy a service manual. 25 bucks. It’ll go through all of that, wiring diagrams, plus more. Scroll down until you get to 2012 RS.

    https://canammanuals.com/can-am-spyder-manual.htm

    And if you don't happen to have an Operators Manual for that thing, you can get one here for free.

    https://www.operatorsguides.brp.com/...9-f5ea4d9dd6a2

    However, have you checked all of your relays to be sure that they are all seated fully? You've got at least 1 that feeds headlights, although the left and right lamps should operate together, but it's an easy check. Pull out your cluster and revisit your headlight connections. Or, there could have been some critter damage. Good Luck with it. You'll get it.
    Last edited by Snowbelt Spyder; Yesterday at 07:25 AM.


    Doug

    2012 Spyder RT LTD Lava Bronze, RT 622, Original Owner, BUDS Megatech License

    ”Freedom is not a loophole”

    Seal Pups, F4 Customs SWCV, Corbin, JT's Air Filter, Cat Bypass, Power Commander V, NBV, SpyderFlap, Rivco Dual Flag Holder, Lidlox, Baja Ron Sway Bar, links, plugs and wires, Adjustable Chrome Side Vents, Spyderpops Block Off Plate and Belt Guard, Bump Skid, Canisterectomy, Akrapovic, TricLed HL/FL and Mag Mirrors, Spyder Cuff with X-Grip, S-Drive, Quatrac 5, Rock Armour, P238, Smoothspyder, Laser Alignment by Gray Ghost, Windshield Arm by Noboot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •