Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Jun 2020
    Location
    Florida
    Posts
    1
    Spyder Garage
    0

    Default 2019 Spyder RT low oil pressure code

    I was riding in to work this morning at about 75 and suddenly the oil light and CEL comes on and an error message to Stop Engine/Low Oil and the bike lost power. Had to limp it the rest of the way at no more than 55. Engine sounds rough. I let it sit for a couple hours and went out to start it up and see if whatever issue may have cleared, but the lights came on immediately and the engine does not sound right at all. Bike has 3400 miles and the first oil change and service was done a little over a month ago at 1100 miles. Not sure if this is a sensor issue or something seriously wrong with the engine.

  2. #2
    Very Active Member trikermutha's Avatar
    Join Date
    Sep 2014
    Location
    USA
    Posts
    3,710
    Spyder Garage
    0

    Default

    Have it towed in under warranty. Dont sound good.

  3. #3
    Active Member
    Join Date
    Dec 2019
    Location
    Land of Lincoln
    Posts
    158
    Spyder Garage
    0

    Default

    You continued on with a fault that told you to "Stop Engine/LowOil"?
    Something caused a loss of oil pressure, and that's what keeps moving components apart during operation.
    Open seat, check for oil on dipstick.
    Look for a puddle, or drips from the bottom of the Spyder.
    Hopefully its a wacked out sensor, or wiring came loose, but if an actual loss of oil pressure, the engine is probably toast.
    Good luck, but it sounds like you need a trip to the dealer for some help either way.

  4. #4
    Very Active Member Highwayman2013's Avatar
    Join Date
    Nov 2012
    Location
    North Las Vegas, NV
    Posts
    4,549
    Spyder Garage
    1

    Default

    Did you check the oil?
    2016 F3 Limited
    2019 Ryker Rally
    2014 Suzuki V Strom 650
    2020 CSC TT 250

  5. #5
    Active Member RowdyScamp's Avatar
    Join Date
    Aug 2019
    Location
    Arkansas
    Posts
    39
    Spyder Garage
    1

    Default

    I had a similar problem on my 2018 RT on July 1, just a week after first service. I used roadside assistance to get it to the dealer. After it was checked out, the service manager advised me that the gears that run the oil pumps broke.
    My Spyder is still in the shop, parts on back-order until some time next month. It needs part number 420435170; they have one but are waiting on a second one.

    Good luck with yours!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •