Results 1 to 6 of 6
  1. #1
    Member gmiller's Avatar
    Join Date
    Feb 2020
    Location
    Jacksonville FL
    Posts
    2
    Spyder Garage
    0

    Default RT Shudder when starting out my day

    I have a "new to me" 2013 RT SE5. I've noticed a significant "SHUDDER" when I first use the Spyder each day, and it seems to be getting worse. Once I drive it down the street and come to the first stop sign it's basically done shuddering for the day, and it only happens when I go from 0 mph and begin heading down the driveway. So clearly it improves as the engine warms up. I've added a LaMonster belt tensioner and that helped in the other power bands but made no difference for my morning starting issue. I check oil as per the BRP instructions and have it halfway between add and full on the stick when checking after the engine is at operating temperature and I let it sit for a couple minutes after shutting it off. I suspect something with the clutch, and it could be "normal" I just have had no prior experience to gauge this issue. Incidentally when I say "SHUDDER" I mean it really does jump around a lot, the bars shake in my hands and I can hear it complaining. The dealer "told me" that they changed the oil when I bought it at 8250 miles. I now have 9100 miles on it. I hope I've answered all the questions about what it's doing and what I've done so far...looking forward to some insight from those who've perhaps seen this issue before?

    Thanks so much!!

  2. #2
    Active Member
    Join Date
    Jun 2016
    Location
    indpls in
    Posts
    295
    Spyder Garage
    0

    Default

    top off the oil to full mark

  3. #3
    Active Member RapidSpyder's Avatar
    Join Date
    Jun 2017
    Location
    Rapid City, SD
    Posts
    382
    Spyder Garage
    1

    Default

    Wonder if dumping half a can of Seafoam in the tank might help?
    Trent - 2017 asphalt grey RT Limited, yes I need to update my pic.
    Ultimate Seat, Baha Ronís sway bar, Kumho rear tire.



    HE>I

  4. #4
    Very Active Member Snowbelt Spyder's Avatar
    Join Date
    Nov 2015
    Location
    Chardon, OH
    Posts
    725
    Spyder Garage
    0


    Doug

    2012 Spyder RT LTD Lava Bronze, RT 622

    Original Owner

    Seal Pups, F4 Customs SWCV, Corbin, JT's Air Filter, Cat Bypass, Power Commander V, NBV, SpyderFlap, Rivco Dual Flag Holder, Lidlox, Baja Ron Sway Bar, links, plugs and wires, Adjustable Chrome Side Vents, Spyderpops Block Off Plate and Belt Guard, Bump Skid, Canisterectomy, Akrapovic, TricLed HL/FL, Spyder Cuff with X-Grip, S-Drive, Rock Armour, P238, Laser Alignment by Gray Ghost, Windshield Arm by Noboot, Vibration Dampener by Doc.

  5. #5
    Very Active Member IdahoMtnSpyder's Avatar
    Join Date
    Jan 2014
    Location
    Idaho
    Posts
    7,006
    Spyder Garage
    1

    Default

    Quote Originally Posted by gmiller View Post
    I have a "new to me" 2013 RT SE5. I've noticed a significant "SHUDDER" when I first use the Spyder each day,
    Well known problem. Snowbelt's link has the answer. I dealt with the same thing when I had my 2013 RT.

    2014 Copper RTS

    Tri-Axis bars, CB, BajaRon sway bar & shock adjusters, SpyderPop's Bumpskid, NBV peg brackets, LED headlights and modulator, Wolo trumpet air horns, trailer hitch, custom trailer harness, high mount turn signals, Custom Dynamics brake light, LED turn signal lights on mirrors, LED strip light for a dash light, garage door opener, LED lights in frunk, trunk, and saddlebags, RAM mounts and cradles for tablet (for GPS) and phone (for music), and Smooth Spyder belt tensioner.

  6. #6
    Member gmiller's Avatar
    Join Date
    Feb 2020
    Location
    Jacksonville FL
    Posts
    2
    Spyder Garage
    0

    Default

    That TST appears to be exactly what I am dealing with. Thanks for the info!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •