Results 1 to 15 of 15
  1. #1
    Member
    Join Date
    Aug 2019
    Location
    Carrying Place
    Posts
    4
    Spyder Garage
    0

    Default Fuel is my Crankcase

    I checked my oil level and it was high, I drained it to the appropriate level ran the engine to temperature, I checked it again and it was foaming and again way over the max level.
    It smells like fuel...
    Could it be a stuck injector?

  2. #2
    Very Active Member JayBros's Avatar
    Join Date
    Jul 2014
    Location
    Mint Hill, NC
    Posts
    5,050
    Spyder Garage
    0

    Default

    Year and Model Spyder?
    Artillery lends dignity to what would
    otherwise be a vulgar brawl.
    ******************************
    Cognac 2014 RT-S

  3. #3
    Very Active Member Grandpot's Avatar
    Join Date
    Oct 2014
    Location
    Fort Mill, SC
    Posts
    1,936
    Spyder Garage
    0

    Default

    Is it running normally or rough with less power? Does the oil have milky streaks or is the foam the normal color of the oil? Has your coolant level dropped?
    2011 RTS (Sold to a very nice lady)
    1998 Honda Valkyrie
    2006 Mustang GT. Varooooom!
    US Navy Veteran
    SC Law Enforcement Boat Captain
    CNC Machine Service Technician
    President: Rolling Thunder SC1
    Member: Disabled American Veterans, Rock Hill, SC
    Member: American Legion
    Experience is recognizing the same mistake every time you make it!

  4. #4
    SpyderLovers Sponsor BajaRon's Avatar
    Join Date
    Aug 2007
    Location
    Greeneville, TN
    Posts
    11,831
    Spyder Garage
    0

    Default

    Are you sure the fuel smell is coming from the oil? Getting it analyzed will not only confirm one way or the other. But also tell you how much, if any, fuel is in your oil.

    BRP oil tends to foam more than most. Hard to say just by this, though I'm assuming you're saying it is foaming more than usual.

    Could be a leaking injector allowing fuel into the cylinder after shutdown. That would definitely do it.
    Only SLOW people have to leave on time...





  5. #5
    Very Active Member Chupaca's Avatar
    Join Date
    Oct 2012
    Location
    San Diego, CA.
    Posts
    31,102
    Spyder Garage
    1

    Default Little checking.....

    Throttle body takes it time shutting down and if you have any leaking going on it would allow that amount to get through. After a few rydes this could become a significant amount. Your oil would become a lot thinner along with the smell of gasoline. You could compare some fresh oil to the oil in the motor and see if can notice a difference.
    Gene and Ilana De Laney
    Mt. Helix, California

    ​2012 RS sm5
    2012 RS sm5 , 998cc V-Twin 106hp DIY brake and park brake Classic Black

  6. #6
    Member
    Join Date
    Aug 2019
    Location
    Carrying Place
    Posts
    4
    Spyder Garage
    0

    Default

    It’s. an 08 RS manual.. 27000KM’s

  7. #7
    Member
    Join Date
    Aug 2019
    Location
    Carrying Place
    Posts
    4
    Spyder Garage
    0

    Default

    It is running fine, the oil foams some. I drained it down again to the full line .
    I am going to do an oil change and run it a few KM’s to see if it recreates the issue.

  8. #8
    Very Active Member Freddy's Avatar
    Join Date
    Dec 2009
    Location
    West Oz
    Posts
    755
    Spyder Garage
    1

    Default

    There's nothing wrong with it. Your imagination is too active.
    The best substitute for brains & knowledge is....................silence.

  9. #9
    Very Active Member
    Join Date
    Dec 2015
    Location
    Oakley, Utah & Yuma, Arizona
    Posts
    6,208
    Spyder Garage
    2

    Default

    And God is my copilot?

    2014 RTL Platinum & 2014 RTL Cognac
    Northern Utah in summer; Yuma, AZ in winter.
    2014 RTL , Lamonster larger pedal Cognac

  10. #10
    Active Member ozzie's Avatar
    Join Date
    Jul 2009
    Location
    pearland, texas
    Posts
    166
    Spyder Garage
    0

    Default

    Did you ever figure out the problem? I'm having the same issue after being in storage for a year. 09 gs manuel. I checked oil before ride. Got about 20 miles down the rode and the bike shut off while riding. Checked oil it was full to the top of the dipstick and smelled like fuel. Spark plugs look good still. Any ideas?
    09 Phanthom

  11. #11
    Very Active Member Mikey's Avatar
    Join Date
    Sep 2017
    Location
    Durham,Maine
    Posts
    1,818
    Spyder Garage
    1

    Default

    Quote Originally Posted by ozzie View Post
    Did you ever figure out the problem? I'm having the same issue after being in storage for a year. 09 gs manuel. I checked oil before ride. Got about 20 miles down the rode and the bike shut off while riding. Checked oil it was full to the top of the dipstick and smelled like fuel. Spark plugs look good still. Any ideas?
    You said you checked oil before the ride!! You warmed it up till the fan came on right?? Then checked it??
    2012 RTL , Pearl

  12. #12
    Very Active Member Bfromla's Avatar
    Join Date
    Aug 2014
    Location
    Bossier loUiSiAna
    Posts
    4,768
    Spyder Garage
    1

    Default

    Operating temperature a must on 998 oil checks oh ya parked on level Surface with good air pressure in tires too

    2013 STL SE5 BLACK CURRANT
    SpyderPop's: LED bumpskid
    SmoothSpyder: dualmode back rest
    T r * * LED:foam grip covers, Tricrings, FenderZ,
    brake light strips, wide vue mirrors
    Rivico SOMA modulation brake leds
    sawblade mowhalk fender accents
    minispyder dash toy
    Lid lox
    KradelLock
    Pakitrack
    GENSSI ELITE LED H4 headlights
    FLO (Frunk Lid Organizer)
    BRP fog lights, trailer hitch & 622 trailer (with its own list: Spyderpops Lighted Rear Bumpskid, LineX protection on sides, led trim lighting amber front& red rear, stand& tongue handle)THX Cruzr Joe!
    (pics in album)
    SENA 20S EVO
    2013 STL , Stock Stock Black currant

  13. #13
    Active Member ozzie's Avatar
    Join Date
    Jul 2009
    Location
    pearland, texas
    Posts
    166
    Spyder Garage
    0

    Default

    Yes, oil was checked properly. I drained the gas today. Does anyone know if to much seafoam may do this? I added half the bottle before ride...9oz vs 5oz that's recommended
    09 Phanthom

  14. #14
    Very Active Member Mikey's Avatar
    Join Date
    Sep 2017
    Location
    Durham,Maine
    Posts
    1,818
    Spyder Garage
    1

    Default

    Seafoams not the problem! It running fine, but is dumping gas in the base, it's just not all adding up!!!! If it was a injector it would be running rough! Rings ,valves, pistons, it would not be running good! EGR, PCP valves ????
    2012 RTL , Pearl

  15. #15
    SpyderLovers Sponsor BajaRon's Avatar
    Join Date
    Aug 2007
    Location
    Greeneville, TN
    Posts
    11,831
    Spyder Garage
    0

    Default

    Quote Originally Posted by Mikey View Post
    You said you checked oil before the ride!! You warmed it up till the fan came on right?? Then checked it??
    The fans come on when the coolant is moving above operating temperature. Unless you're actually riding your Spyder, the coolant temperature has virtually nothing to do with your oil temperature. It is the oil, not the coolant, that needs to be at operating temperature. Letting your Spyder idle long enough for the coolant to come to operating temperature is hard on the engine. Best to ride it.
    Only SLOW people have to leave on time...





Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •