Results 1 to 13 of 13
  1. #1
    Member
    Join Date
    Apr 2019
    Location
    Medway Ohio
    Posts
    8
    Spyder Garage
    0

    Default Hardlurch to left when braking.

    We noticed on our first ride of the season earlier
    this year that our 2013 RT ltd (current miles 6927)
    Really get squirrelly on moderate to firm braking.
    The right suspension compressed and it would lurch hard to left giving the ABS and stability system fits.
    I suspected a seized left shock or a left caliper not getting any brake fluid pressure.
    I bounce tested both sides and shocks seem to compress equally.
    With wheels in air and brake applied, i cant turn either wheel.
    Inner and outer pads on both sides are fairly equal in thickness.
    Of course I cant duplicate the turning force of a rolling chasis by hand! But, both front brakes do clamp onto the rotors and release when pedal is released.
    Brake fluid is full.
    I can't find anything loose (tie rods etc) in steering linkage.
    Honestly, it's dangerous on dry pavement at anything over 50MPH.
    On wet pvement or in a severe braking situation, it could be very bad
    I'm at a loss to figure it out.
    Any suggestions?

  2. #2
    Very Active Member Bfromla's Avatar
    Join Date
    Aug 2014
    Location
    Bossier loUiSiAna
    Posts
    4,046
    Spyder Garage
    1

    Default

    Check for rotor warping

    2013 STL SE5 BLACK CURRANT
    SpyderPop's: LED bumpskid
    SmoothSpyder: dualmode back rest
    T r * * LED:foam grip covers, Tricrings, FenderZ &brake light strips,
    wide vue mirrors
    Lid lox
    sawblade mowhalk fender accents
    minispyder dash toy
    Pakitrack
    FLO (Frunk Lid Organizer)
    BRP trailer hitch & 622 trailer (with its own list: Spyderpops Lighted Rear Bumpskid, LineX protection on sides, led trim lighting amber front& red rear, stand& tongue handle)THX Cruzr Joe!
    (pics in album)

  3. #3
    Very Active Member PMK's Avatar
    Join Date
    Jan 2014
    Location
    SoFlo
    Posts
    2,443
    Spyder Garage
    0

    Default

    Contaminated brake pads and contaminated rotor on one side.

  4. #4
    Very Active Member bscrive's Avatar
    Join Date
    Nov 2012
    Location
    Ottawa, Ontario
    Posts
    1,337
    Spyder Garage
    0

    Default

    Your brakes got hot and one side has lost it's hardness. It happened to my wife's F3 a couple of years ago.

    Change your pads to BajRon's full sintered pads.

  5. #5
    Very Active Member
    Join Date
    Apr 2017
    Location
    North Central Florida
    Posts
    2,492
    Spyder Garage
    0

    Default

    BUT.....before you change out anything......do some practice hard braking in a safe place.

    For me, it is a rider problem.
    Sometimes it pulls left, sometimes right depending on which if my arms is closest to being "stiff" and what my initial reaction to the "hazzard" is.

    On two wheels, I learned to deal with wheels locking and the back end stepping out under hard braking......and keeping the bike upright in the process.
    You likely need to "learn" the braking characteristics of your new ride too.

  6. #6
    Active Member bushrat's Avatar
    Join Date
    Apr 2017
    Location
    Keene, ON, Canada and/or Leesburg, FL
    Posts
    342
    Spyder Garage
    1

    Default

    FWIW, there have been two recent posts describing similar issues with F3L or F3T Spyders, each of which has been suffering from hard pull to one side or the other under heavy braking; see:

    https://www.spyderlovers.com/forums/...ly-to-one-side

    and

    https://www.spyderlovers.com/forums/...-brake-balance

    In my case, my F3L was pulling sharply right, enough to put me on the shoulder of the road rather than stopping in a straight, safe line on pavement. Many opinions were expressed about pads, rotors, fluid levels etc. All those proved NOT to be the cause. My dealer techs discussed the issue with BRP and other dealers who had dealt with similar problems. The fault turned out to be a defective caliper on the 'weak' side. Replacing my left side front calipers (which included new pads) put the bike back in a proper balanced braking operation. New pads were also installed on the right side as part of the 'cure', so that pad wear (on both sides) from this point should be even. The Bike now performs like new. The answer seems to be that calipers can indeed become 'weak' or function insufficiently on one side, thus throwing the braking system off. Calipers can often seem to be the last thing to get looked at, when maybe they should be higher up the list as a possible cause.

    Just putting this out there for other to be aware of.
    [SIGPIC]
    2017 F3 Ltd. Intense Red Pearl/Metallic Black topside

  7. #7
    Member
    Join Date
    Apr 2019
    Location
    Medway Ohio
    Posts
    8
    Spyder Garage
    0

    Default

    Quote Originally Posted by bushrat View Post
    FWIW, there have been two recent posts describing similar issues with F3L or F3T Spyders, each of which has been suffering from hard pull to one side or the other under heavy braking; see:

    https://www.spyderlovers.com/forums/...ly-to-one-side

    and

    https://www.spyderlovers.com/forums/...-brake-balance

    In my case, my F3L was pulling sharply right, enough to put me on the shoulder of the road rather than stopping in a straight, safe line on pavement. Many opinions were expressed about pads, rotors, fluid levels etc. All those proved NOT to be the cause. My dealer techs discussed the issue with BRP and other dealers who had dealt with similar problems. The fault turned out to be a defective caliper on the 'weak' side. Replacing my left side front calipers (which included new pads) put the bike back in a proper balanced braking operation. New pads were also installed on the right side as part of the 'cure', so that pad wear (on both sides) from this point should be even. The Bike now performs like new. The answer seems to be that calipers can indeed become 'weak' or function insufficiently on one side, thus throwing the braking system off. Calipers can often seem to be the last thing to get looked at, when maybe they should be higher up the list as a possible cause.

    Just putting this out there for other to be aware of.
    I think you nailed it bushrat.
    I have noticed tho that if I really btake hard a couple times, like I was trying to do what us two wheelers call a "Stoppie", the pull is greatly reduced.
    And..
    Although it's barely discernable the right rotor is slightly darker than the left.
    I'm going to take a "shotgun" approach.
    But go the cheapskate route.
    Clean and sand pads both sides, scruff and clean rotor, right side and clean and lube the left caliper slides.
    I can only imagine the cost of a new Brembo caliper!!!
    Thanks Everyone!!!!
    I really appreciate the help!!!

  8. #8
    Very Active Member PMK's Avatar
    Join Date
    Jan 2014
    Location
    SoFlo
    Posts
    2,443
    Spyder Garage
    0

    Default

    Quote Originally Posted by Wozerd View Post
    I think you nailed it bushrat.
    I have noticed tho that if I really btake hard a couple times, like I was trying to do what us two wheelers call a "Stoppie", the pull is greatly reduced.
    And..
    Although it's barely discernable the right rotor is slightly darker than the left.
    I'm going to take a "shotgun" approach.
    But go the cheapskate route.
    Clean and sand pads both sides, scruff and clean rotor, right side and clean and lube the left caliper slides.
    I can only imagine the cost of a new Brembo caliper!!!
    Thanks Everyone!!!!
    I really appreciate the help!!!
    No caliper slides. If you are planing to clean the pads and rotors, visually inspect for a weep of fluid from the caliper piston on the softer brake side. Not a gushing leak. Troubleshooting ours, my first step swapped tires left to right, issue still remained. Next swapped pads and rotors from side to side, issue moved to opposite side. Washed disc and installed a used set of pads, machine had even braking. Went back and inspected for leaks, found slightest trace of dampness in brake dust around one of the four pistons. Cleaned both calipers, reset pistons and cleaned again. Installed new brake pads, moved discs to original locations, tires too. Issue solved.

    Most times a warped or bent disc creates pulsing in how the machine stops and into the steering. An overheated brake can do odd things but most times will warp or again have pulsing. Not sure what a weak caliper is, sounds like a poor forging let the caliper flex, hydraulically, each side generates equal clamping pressure.

    Regardless, whatever you find it to be, good luck with it.

  9. #9
    Active Member bushrat's Avatar
    Join Date
    Apr 2017
    Location
    Keene, ON, Canada and/or Leesburg, FL
    Posts
    342
    Spyder Garage
    1

    Default

    Quote Originally Posted by Wozerd View Post
    ... I can only imagine the cost of a new Brembo caliper!!!
    Thanks Everyone!!!!
    I really appreciate the help!!!
    Wozerd, I was lucky. Had 2 weeks left on my full BRP warranty, so malfunctioning caliper and new brake pads were replaced free of charge. However, had I to pay, I was told the calipers would have cost about $465 CAN, or roughly $350 US, inclusive of all taxes (13%), federal and provincial.

    Hope you get fixed up without undue/excessive cost.
    [SIGPIC]
    2017 F3 Ltd. Intense Red Pearl/Metallic Black topside

  10. #10
    Active Member
    Join Date
    Sep 2014
    Location
    Scotland
    Posts
    110
    Spyder Garage
    0

    Default

    Quote Originally Posted by Wozerd View Post
    I think you nailed it bushrat.
    I have noticed tho that if I really btake hard a couple times, like I was trying to do what us two wheelers call a "Stoppie", the pull is greatly reduced.
    And..
    Although it's barely discernable the right rotor is slightly darker than the left.
    I'm going to take a "shotgun" approach.
    But go the cheapskate route.
    Clean and sand pads both sides, scruff and clean rotor, right side and clean and lube the left caliper slides.
    I can only imagine the cost of a new Brembo caliper!!!
    Thanks Everyone!!!!
    I really appreciate the help!!!
    As well as cleaning and lubing the pad slide area, while the pads are out pump the brake and drive the pistons out a distance - don't go too far! - and watch for one of them being a little reluctant. Squeeze them in and exercise them a couple more times to be sure they are as free to move as they would be when new.

    The fact that they work ok after you've applied them hard a couple of times is the clue to something not being quite as free to move as it should be.

  11. #11
    Member
    Join Date
    Apr 2019
    Location
    Medway Ohio
    Posts
    8
    Spyder Garage
    0

    Default

    Well, the proper thing I suppose is following up with my results.
    I had a hard time accepting that Brembo, one of the icons of brake manufacturers in the world, would put out a product that would include a high incidence of "weak" calipers.
    Long story short.
    I bled the lines.. no air.
    I took both calipers off and inspected them, the pads and rotors.
    The right caliper was slightly discolored as were the pads in comparison the the Left side.
    Remember.. it pulled hard Left when braking even normally.
    I cleaned the right caliper and pads with Wearever brand brake clean.
    Hosed it all down.. big time.
    The first stop was disappointing. Pull still there.. but barely a bit less than before.
    Each hard stop showed less and less pull.
    Now.. it stops straight arrow after less than 50 miles.
    I can only guess I contaminated the rotor, and then the pads with a spray wax I use to polish the chrome wheels.
    Either way.. problem solved.
    Thanks for everyone's help and advice!!!

  12. #12
    SpyderLovers Sponsor BajaRon's Avatar
    Join Date
    Aug 2007
    Location
    Greeneville, TN
    Posts
    10,623
    Spyder Garage
    0

    Default

    Quote Originally Posted by Wozerd View Post
    Well, the proper thing I suppose is following up with my results.
    I had a hard time accepting that Brembo, one of the icons of brake manufacturers in the world, would put out a product that would include a high incidence of "weak" calipers.
    Long story short.
    I bled the lines.. no air.
    I took both calipers off and inspected them, the pads and rotors.
    The right caliper was slightly discolored as were the pads in comparison the the Left side.
    Remember.. it pulled hard Left when braking even normally.
    I cleaned the right caliper and pads with Wearever brand brake clean.
    Hosed it all down.. big time.
    The first stop was disappointing. Pull still there.. but barely a bit less than before.
    Each hard stop showed less and less pull.
    Now.. it stops straight arrow after less than 50 miles.
    I can only guess I contaminated the rotor, and then the pads with a spray wax I use to polish the chrome wheels.
    Either way.. problem solved.
    Thanks for everyone's help and advice!!!
    Thank you for the follow-up. Not everyone does this and it can be quite valuable. I saw this tread originally and did not comment because there didn't seem to be enough information to make a reasoned response. I pretty much ruled out warped rotor as that brings a very annoying set of effects that I am sure you would have mentioned. Glad you got it worked out. I am sure others will find this useful. With the open spoke design, it is important to be careful what you are spraying that will go past the wheel to the rotor and then to the pads.
    Only SLOW people have to leave on time...





  13. #13
    Active Member
    Join Date
    Jul 2019
    Location
    UK
    Posts
    78
    Spyder Garage
    0

    Default

    Quote Originally Posted by Wozerd View Post
    Well, the proper thing I suppose is following up with my results.
    I had a hard time accepting that Brembo, one of the icons of brake manufacturers in the world, would put out a product that would include a high incidence of "weak" calipers.
    Long story short.
    I bled the lines.. no air.
    I took both calipers off and inspected them, the pads and rotors.
    The right caliper was slightly discolored as were the pads in comparison the the Left side.
    Remember.. it pulled hard Left when braking even normally.
    I cleaned the right caliper and pads with Wearever brand brake clean.
    Hosed it all down.. big time.
    The first stop was disappointing. Pull still there.. but barely a bit less than before.
    Each hard stop showed less and less pull.
    Now.. it stops straight arrow after less than 50 miles.
    I can only guess I contaminated the rotor, and then the pads with a spray wax I use to polish the chrome wheels.
    Either way.. problem solved.
    Thanks for everyone's help and advice!!!
    I'm pleased you've got it sorted. Perhaps it was your wax polish but I doubt it. What you've found is fairly common, multiple hard braking - you've kinda serviced the brakes. You've refaced the pads and the discs, you've exercised the caliper pistons and you've made the pads slide in the caliper more than usual. It's probable that you're a smooth rider, backing off the throttle for corners, assessing the road ahead etc and use your brakes fairly lightly except for the the odd occasion. If so, do a few deliberate forceful brakings occasionally.
    Rule#2: Never argue with an idiot. He'll drag you down to his level & then beat you with experience.
    Rule#1: Refer to rule #2.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •