Results 1 to 16 of 16
  1. #1
    Active Member RangerRick's Avatar
    Join Date
    Jul 2022
    Location
    Coos Bay, Oregon
    Posts
    100
    Spyder Garage
    0

    Default Any ideas why it sometimes quits on a Cold start?

    Any Idea why it does this, some times it quits when it first bogs down, today it idled ok once the rpm dropped. When it dies I have to give it throttle when restarting and after a couple of twist on the throttle it idles fine, runs great when warmed up. Has new plug wires and plugs and new silicone vacuum lines on throttle bodies. maybe needs new 02 sensors? 2013 ST 998cc. Was not touching the throttle.

    https://youtube.com/shorts/QUq6Bf3P6YM?feature=share
    Last edited by Peter Aawen; 11-24-2022 at 03:13 AM. Reason: Expanded Title to briefly ask the question ;-)
    2013 Spyder ST-SE5

  2. #2
    Very Active Member
    Join Date
    Feb 2010
    Location
    western Colorado
    Posts
    1,086
    Spyder Garage
    0

    Default

    Have you checked the battery?
    Start and watch headlights. If flickering battery is low

  3. #3
    Active Member RangerRick's Avatar
    Join Date
    Jul 2022
    Location
    Coos Bay, Oregon
    Posts
    100
    Spyder Garage
    0

    Default

    Quote Originally Posted by happyspyder2039 View Post
    Have you checked the battery?
    Start and watch headlights. If flickering battery is low
    The battery is 4 months old and lights stay bright no flickering
    2013 Spyder ST-SE5

  4. #4
    Active Member Isopedella's Avatar
    Join Date
    Feb 2022
    Location
    New Zealand
    Posts
    321
    Spyder Garage
    1

    Default

    Have you replaced your fuel filter and cleaned your air filter.
    This thread of yours refers...
    https://www.spyderlovers.com/forums/...-issue-2013-ST

  5. #5
    Active Member Isopedella's Avatar
    Join Date
    Feb 2022
    Location
    New Zealand
    Posts
    321
    Spyder Garage
    1

    Default

    Quote Originally Posted by RangerRick View Post
    The battery is 4 months old and lights stay bright no flickering
    So what. Have you checked they are connected correctly. Sitting stationary is a little different than driving down the road.

  6. #6
    Very Active Member Mikey's Avatar
    Join Date
    Sep 2017
    Location
    Durham,Maine
    Posts
    2,789
    Spyder Garage
    1

    Default

    Try putting a bottle of seafoam in it!
    2012 RTL , Pearl

  7. #7
    SpyderLovers Sponsor BajaRon's Avatar
    Join Date
    Aug 2007
    Location
    Greeneville, TN
    Posts
    12,464
    Spyder Garage
    0

    Default

    Quote Originally Posted by RangerRick View Post
    Any Idea why it does this, some times it quits when it first bogs down, today it idled ok once the rpm dropped. When it dies I have to give it throttle when restarting and after a couple of twist on the throttle it idles fine, runs great when warmed up. Has new plug wires and plugs and new silicone vacuum lines on throttle bodies. maybe needs new 02 sensors? 2013 ST 998cc. Was not touching the throttle.

    https://youtube.com/shorts/QUq6Bf3P6YM?feature=share
    Did you look at your valves through the throttle bodies when you had the air box off? Was there any oil residue in the air box? Did you spray down the internals on the throttle body with Chemtool or similar? The valves can get pretty nasty. Especially if there is oil vapor coming out of your crankcase vent into the airbox. Putting the engine at TDC closes all valves and you can then soak them with Chemtool to clean things up.

    Running a good fuel injection cleaner in the fuel can help if the injectors are a bit boggy.
    Only SLOW people have to leave on time...





  8. #8
    Active Member RangerRick's Avatar
    Join Date
    Jul 2022
    Location
    Coos Bay, Oregon
    Posts
    100
    Spyder Garage
    0

    Default

    Quote Originally Posted by BajaRon View Post
    Did you look at your valves through the throttle bodies when you had the air box off? Was there any oil residue in the air box? Did you spray down the internals on the throttle body with Chemtool or similar? The valves can get pretty nasty. Especially if there is oil vapor coming out of your crankcase vent into the airbox. Putting the engine at TDC closes all valves and you can then soak them with Chemtool to clean things up.

    Running a good fuel injection cleaner in the fuel can help if the injectors are a bit boggy.
    I admit I did not look down the throttle bodies with a mirror, I did spray Chemtool down them but it was not a straight shot in. And yes the air box was full of oil, but cleaned that up and ran the Crankcase vent out the bottom of the bike, passing through the glass tube with the foam inside. I have run both Sea Foam and Throttle Body Cleaner through it. Sounds like I need to check the valves and soak if needed.
    Last edited by Peter Aawen; 11-24-2022 at 04:01 PM. Reason: Caps + rann - run ;-)
    2013 Spyder ST-SE5

  9. #9
    Active Member RangerRick's Avatar
    Join Date
    Jul 2022
    Location
    Coos Bay, Oregon
    Posts
    100
    Spyder Garage
    0

    Default

    Quote Originally Posted by Isopedella View Post
    Have you replaced your fuel filter and cleaned your air filter.
    This thread of yours refers...
    https://www.spyderlovers.com/forums/...-issue-2013-ST
    I need to replace the fuel filter, air filter is new 2 months ago, will check the battery connections
    2013 Spyder ST-SE5

  10. #10
    Very Active Member IdahoMtnSpyder's Avatar
    Join Date
    Jan 2014
    Location
    Idaho
    Posts
    9,157
    Spyder Garage
    1

    Default

    2012 & 2013 engines had throttle body issues requiring cleaning and/or replacement. Maybe that's what you're dealing with. Sorry, I don't remember the details. There was a TSB about it.

    2014 Copper RTS

    Tri-Axis bars, CB, BajaRon sway bar & shock adjusters, SpyderPop's Bumpskid, NBV peg brackets, LED headlights and modulator, Wolo trumpet air horns, trailer hitch, custom trailer harness, high mount turn signals, Custom Dynamics brake light, LED turn signal lights on mirrors, LED strip light for a dash light, garage door opener, LED lights in frunk, trunk, and saddlebags, RAM mounts and cradles for tablet (for GPS) and phone (for music), and Smooth Spyder belt tensioner.
    2014 RTS , Copper! (officially Cognac)

  11. #11
    Very Active Member pegasus1300's Avatar
    Join Date
    Feb 2012
    Location
    Spring City,Utah
    Posts
    4,784
    Spyder Garage
    1

    Default

    I can't find that TSB right now, but I don't remember it applying to the 2012s.

    Happy TRAils/NSD
    Paul

    2012 RT L
    AMA 25 years Life Member
    TRA
    PGR
    Rhino Riders Plate #83
    Venturers #78
    TOI

    2012 Spyder RT L , Baja Ron Plugs and wires Lava Bronze

  12. #12
    Very Active Member IdahoMtnSpyder's Avatar
    Join Date
    Jan 2014
    Location
    Idaho
    Posts
    9,157
    Spyder Garage
    1

    Default

    Quote Originally Posted by pegasus1300 View Post
    I can't find that TSB right now, but I don't remember it applying to the 2012s.
    Here it is. I just remembered that maybe I still had it from when I had a problem with my 2013 RT!

    https://www.spyderlovers.com/forums/...attach/pdf.gif
    Attached Files Attached Files

    2014 Copper RTS

    Tri-Axis bars, CB, BajaRon sway bar & shock adjusters, SpyderPop's Bumpskid, NBV peg brackets, LED headlights and modulator, Wolo trumpet air horns, trailer hitch, custom trailer harness, high mount turn signals, Custom Dynamics brake light, LED turn signal lights on mirrors, LED strip light for a dash light, garage door opener, LED lights in frunk, trunk, and saddlebags, RAM mounts and cradles for tablet (for GPS) and phone (for music), and Smooth Spyder belt tensioner.
    2014 RTS , Copper! (officially Cognac)

  13. #13
    Very Active Member Mikey's Avatar
    Join Date
    Sep 2017
    Location
    Durham,Maine
    Posts
    2,789
    Spyder Garage
    1

    Default

    I will be keeping this in my files!! Thank you!!
    2012 RTL , Pearl

  14. #14
    SpyderLovers Sponsor BajaRon's Avatar
    Join Date
    Aug 2007
    Location
    Greeneville, TN
    Posts
    12,464
    Spyder Garage
    0

    Default

    Quote Originally Posted by RangerRick View Post
    I admit I did not look down the throttle bodies with a mirror, I did spray Chemtool down them but it was not a straight shot in. And yes the air box was full of oil, but cleaned that up and ran the Crankcase vent out the bottom of the bike, passing through the glass tube with the foam inside. I have run both Sea Foam and Throttle Body Cleaner through it. Sounds like I need to check the valves and soak if needed.
    You don't need a mirror. You can see right down into the throttle body to the valves. If you had oil in your air box. (very common) It would be a good idea to check out those valves. They may be pretty heavily loaded with carbon. If you ran your crankcase vent down to where oil drips out the bottom. Be sure to check your oil level fairly often. The vent mod can be installed so that oil is returned to the crankcase.
    Only SLOW people have to leave on time...





  15. #15
    Active Member RangerRick's Avatar
    Join Date
    Jul 2022
    Location
    Coos Bay, Oregon
    Posts
    100
    Spyder Garage
    0

    Default

    Quote Originally Posted by BajaRon View Post
    You don't need a mirror. You can see right down into the throttle body to the valves. If you had oil in your air box. (very common) It would be a good idea to check out those valves. They may be pretty heavily loaded with carbon. If you ran your crankcase vent down to where oil drips out the bottom. Be sure to check your oil level fairly often. The vent mod can be installed so that oil is returned to the crankcase.
    I forgot to mention I did install the unit in a upright position like it was going towards the air box then curved it back down and out the bottom, so the oil will run back into the engine.
    2013 Spyder ST-SE5

  16. #16
    Active Member RangerRick's Avatar
    Join Date
    Jul 2022
    Location
    Coos Bay, Oregon
    Posts
    100
    Spyder Garage
    0

    Default

    Quote Originally Posted by IdahoMtnSpyder View Post
    Here it is. I just remembered that maybe I still had it from when I had a problem with my 2013 RT!

    https://www.spyderlovers.com/forums/...attach/pdf.gif
    Thanks so much for this info, I printed it out, will be a good winter project for me to do
    2013 Spyder ST-SE5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •