Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Dec 2020
    Location
    Mercedes, TX
    Posts
    6
    Spyder Garage
    0

    Default Problems with Sygic Navigation initial setup with Connect - what am I doing wrong?

    Fat cycle daddy, I just purchased my 2018 Spyder RTL and purchased the Sygic Navigation premium on sale. My problem is I canít get Sygic past the initial setup to use the app. When I click on the grayed
    out
    icon it tells me to click Start which I do then it says click on popup 1 and then Popup 2 on my handset. Nothing shows up on my phone except the map in Sygic. I get no pop ups. Any advise on what Iím doing wrong?

  2. #2
    Member
    Join Date
    Nov 2020
    Location
    Sugarland TX
    Posts
    27
    Spyder Garage
    1

    Default

    The overall disgust I have seen expressed here with BURP Connect have dissuaded me from even trying to use it so far. Will be watching this thread to see if any solutions come up.
    2020 Spyder RT base
    2020 RT , Chalk White

  3. #3
    Member
    Join Date
    May 2016
    Location
    Florida
    Posts
    7
    Spyder Garage
    0

    Default

    Following… Had the same outcome. Misery loves company. Glad it’s not just me!

  4. #4
    Very Active Member Flamewinger's Avatar
    Join Date
    Aug 2013
    Location
    SF Bay Area
    Posts
    1,542
    Spyder Garage
    1

    Default

    Make sure the bike's dash firmware is 20.8. If not then the BRP Connect needs to be open and the phone unlocked.

    Sygic is a stand alone app and doesn't need BRP Connect to work. The BRP Connect app is required for all the apps to work in the bike.

    When opening any app for the first time in the bike dash you need to check the phone for approval popups. OK them and it opens fine after that. When switching to BRP Connect the phone goes dark and if there is a popup you should see it with the dark screen behind.

    There have been some recent iOS updates and it's been found that there is a BRP Connect update. Once that is updated, Sygic works.

    If you have a custom route you need to have Sygic open with the route in the phone first, then connect to the bike and open in the dash. When opening it in the dash sometimes the connectivity screen comes up. When this happens just close it again then re-open. When you see the map you also see icons on the right side. Move the joystick to the right so the 3 dots are highlighted and push in to open the search window. Pick a place and go.

    Susie - 2018 RT-Limited with 16700 miles so far . . .
    '13 Spyder ST-L with 21k miles
    '04 GL1800 with 91k miles
    '97 GL1500 with 87k miles
    '95 GL1500 with 102k miles
    '89 GL1500 with 96k miles
    '83 GL1100 with 117k miles
    '81 Honda Silverwing with 36k miles
    '79 Kaw 400LTD with 26k miles
    GWRRA - 39 yrs - Life Member
    AMA - 40 yrs
    Just remember, if common sense is so common, why do few people have it?
    2018 RT-Ltd , ShowChrome Asphalt Grey (greenish)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •