Results 1 to 4 of 4

Thread: Lights

  1. #1
    Member
    Join Date
    Aug 2016
    Location
    Calverton N.Y.
    Posts
    27
    Spyder Garage
    0

    Default Lights

    2013 can-am RT. Looking for help. Front fender lights and frunk light around the BRP ornament come on and stay on when i first start up. After the bike warms up they start plinking side to side with the front one intermittently plinking.
    This just started this year. The lights have been working since i bought the bike 3 years ago. I have not added any other lights. Not sure how to approach this issue? Any help would be great.
    Thanks
    Robert

  2. #2
    Very Active Member Mazo EMS2's Avatar
    Join Date
    Jan 2015
    Location
    southern WI
    Posts
    1,579
    Spyder Garage
    1

    Default

    Sounds like a loose connection or bad ground, or both.

  3. #3
    Very Active Member DGoebel's Avatar
    Join Date
    Oct 2016
    Location
    Faribault, MN
    Posts
    1,807
    Spyder Garage
    1

    Default

    The Frunk light around the ornament is an add-on, it may be where it that connects into the stock harness.
    Safe Rides,
    David and Sharon Goebel
    Both Retired USAF Veterans
    2013 RT Limited, Pearl White
    Farkles too numerous to list
    See my Spyder Garage
    IBA 70020

  4. #4
    Member
    Join Date
    Aug 2016
    Location
    Calverton N.Y.
    Posts
    27
    Spyder Garage
    0

    Default

    Thanks. Wiil check that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •