Results 1 to 19 of 19
  1. #1
    Active Member
    Join Date
    Apr 2013
    Location
    Republic of Ireland
    Posts
    62
    Spyder Garage
    0

    Default 2019 RT LTD dropping connection to BRP Connect while plugged in to USB in frunk

    Hi everyone, just wondering if anyone else is having this problem.

    I have Genius maps up on my screen driving along and then suddenly the screen goes blank and I get a spinning wheel icon and then a notification telling me to "connect phone". The phone is connected to the usb in the frunk and the Spyder is running but it is dropping the connection. This has happened to me many times during a ride or when stopped with the engine still running. Every time I have Genius maps visible on the screen and for no reason the screen goes blank and the notification is to connect phone which is already connected. It appears to me a problem with either the USB connection or BRP Connect. I have also tried two other genuine apple cables (its an iPhone 8 Plus I'm using) and still the same. I have the latest firmware update.

    I would really appreciate knowing if anyone else has this issue.

    The Spyder is only a couple of months old and I had to have the alternator replaced after a few weeks as it was wired incorrectly from factory. BRP said it was the only Spyder to have this issue in 2019. I'm wondering if the issue I'm now having with BRP Connect could be in any way related?

    Many thanks for any assistance.

  2. #2
    Active Member
    Join Date
    Jun 2019
    Location
    Canuckistan
    Posts
    82
    Spyder Garage
    0

    Default

    Howdy;

    Troubleshootin' 101 - change only one thing at a time. Assess results. Rinse & repeat.


    You've already ruled out the cable. Do you know anyone with another phone with the same IOS version?

    Tried uninstalling and reloading the app?

    Tried another device in the USB port? (possibly without using BRP Connect).

    Asked the dealer to pull any existing codes?

    I recognize it may be rather difficult to try another RT

    On the build error - that is a very chilling observation. Not certain it's the root cause here, though. Leverage yer warranty and rights.


    Best o' luck! Please post what you discover in yer diagnosis.

    Cheers
    E

  3. #3
    Active Member
    Join Date
    Sep 2018
    Location
    greensburg,pa
    Posts
    229
    Spyder Garage
    1

    Default

    Maybe the usb connection (phone cable) lose or dirty. Never had an issue with my 2018 using a Pixel phone.
    Try wiggling the cable(s) and try to duplicate the problem and if that's it try some contact cleaner or maybe its the main usb cable is lose behind the frunk.
    2018 RT-L Dark

    Lamonster LED upgrade Headlamp/fogs
    BRP Comfort heated seat

  4. #4
    Very Active Member Cruzr Joe's Avatar
    Join Date
    Jul 2012
    Location
    Bryant, Arkansas
    Posts
    9,742
    Spyder Garage
    0

    Default

    do you have ver. 20.8 software on your cluster panel??

    this is the latest upgrade for the digital cluster

    Cruzr Joe
    [SIZE=4]2018 F3 Limited, BRP Driver Backrest, Spyderpops Lighted Bump Skid, Dual Spyclops Light, Mirror Turn Signals, Laser Alignment, Engine LEDs, Fog Lights With Halo's, Cushion Handgrips, BRT LEDs, and Under Lighting, Lamonster IPS, (with Clock), F4 25" Vented Windshield with Wings, Airhawk "R" Cushions. Position 4 Brake setting, Short reach Handlebars, Dash Mounted Voltmeter and 12 Volt Plug. Set of 3rd pegs. Extended Passenger Seat. Exterior BRP Connect setup, Ultimate Trailer/SIZE]

  5. #5
    Active Member
    Join Date
    Apr 2013
    Location
    Republic of Ireland
    Posts
    62
    Spyder Garage
    0

    Default

    Thanks everyone for the help.
    I have tried everything except another RT which isn’t possible unfortunately and I have the current 20.8 software. My worry is that I have bought a Monday morning Spyder !!
    The problem isn’t there all the time continuously - it happened yesterday about an hour into my ride and then again about 20 mins later. Previously it happened about 10 mins into the ride.
    My worry is that since the alternator was wired incorrectly from the factory is this yet another fault from the factory.
    I am hoping that someone else with a brand new 2019 RT has the same issue or else it looks like I got a dud!
    I love the RT but having these problems on a brand new Spyder is not right.

  6. #6
    Member Sumetrap's Avatar
    Join Date
    Jun 2019
    Location
    Bear,Delaware
    Posts
    20
    Spyder Garage
    1

    Default

    I'm picking my 2019 RTL up tomorrow and will keep you posted. Certainly hoping for a different outcome however.
    2019 RT Limited
    BRP Comfort seat
    Triaxis handlebars
    Lamonster highway pegs
    Lamonster spydercuff
    Lidlocks

    Nicknamed "Moody Blues" because it is what I will be riding to cure them...

  7. #7
    Very Active Member jcthorne's Avatar
    Join Date
    Sep 2013
    Location
    Houston
    Posts
    5,106
    Spyder Garage
    1

    Default

    The sooner you get a real Garmin GPS on the bike and give up on the half baked BRP Connect system that is never going to be supported well the sooner you will be riding without the problems. The digital dash works fine for instruments and the built in radio. Forget the apps and remote navigation kluge.

    Its NEVER going to be Android Auto or Apple Car Play. BRP simply does not have the budget or software expertise to ever pull that off on their own. They should have gone with a proven well supported system rather than trying to reinvent the wheel.

    Blue Flame Spyder F3-S

  8. #8
    Member
    Join Date
    Jun 2019
    Location
    KY
    Posts
    2
    Spyder Garage
    0

    Default

    I just bought a 2019 Spyder RT Limited Dark Edition and it should be coming in today 6/19, I hope. My wife will be riding it most, but I bought her a brand new iPod for her music and the BRP Connect app. I'll post if I find any issues.

  9. #9
    Active Member Ride2GetHigh's Avatar
    Join Date
    Jun 2018
    Location
    Nipomo, Calif
    Posts
    55
    Spyder Garage
    0

    Default

    As I have written in the past and even more since getting the latest firmware upgrade I'll say it again. DON'T USE THE BRP CONNECT!!! There are way to many horror stories working with it and keeping it working. Since I have never used it or the maps app or such I don't have any experience first hand but doing what I do can't be better.

    I have an X mount on my steering head. My Android phone goes there. I have a Sena 5 head set (the one without a radio in it). I turn on my headset, start the bike and the two are connected. I can listen to the bike radio through the headset and control it with the jog dial. I THEN turn the BT on my phone and it connects to the bike for audio and phone (my phonebcontact list shows on the dash). I now have the choice to play music from my phone (Bluetooth setting on the bike) or the FM radio setting on the bike. When I want to ask Google for directions I just light up the screen on my phone and talk into the mic on my helmet. I tell her where I want to go and she takes me there. Audio instructions in my helmet and the map on the screen on my phone. What you say? Well the screen on my phone is not only closer to me than the dash but it didn't cost me a thing. It always works great and no connection issues (of course if you don't have cell service which is very rarely with Verizon.)

    Your mileage may vary but that's what I do and it works for me. Nothing plugged into the frunk or trunk or anything to do with the BRP connect.....
    Happy riding.....


    2018 Spyder RT
    Custom Pinstriping by Fastripe.com see video @ https://www.dropbox.com/s/5icsez0g0w...iping.mp4?dl=0
    18" floor boards
    Ram mount phone X holder
    Ram mount cup holder

  10. #10
    Very Active Member Flamewinger's Avatar
    Join Date
    Aug 2013
    Location
    SF Bay Area
    Posts
    1,211
    Spyder Garage
    1

    Default

    I tend to use Sygic more than Genis. Ive had the lost connection but it recovers and while it's blank I still hear directions and music. I think this is something we need to tell our dealers d BRP Care so they can figure it out. Instead of avoiding it I they my best to learn how it works and once I get used to it, I find that whatever I'm learning becomes easier to use.

    Susie - 2018 RT-Limited with 8400 miles so far . . .
    '13 Spyder ST-L with 21k miles
    '04 GL1800 with 91k miles
    '97 GL1500 with 87k miles
    '95 GL1500 with 102k miles
    '89 GL1500 with 96k miles
    '83 GL1100 with 117k miles
    [/COLOR]'81 Honda Silverwing with 36k miles
    '79 Kaw 400LTD with 26k miles
    GWRRA - 39 yrs - Life Member
    AMA - 39 yrs
    Just remember, if common sense is so common, why do few people have it?

  11. #11
    Active Member
    Join Date
    Apr 2013
    Location
    Republic of Ireland
    Posts
    62
    Spyder Garage
    0

    Default

    Hi everyone, many thanks for all the replies and information.
    We have emailed BRP and complained about the issues we have had with our new RT - the latest issue being the dropping of the connection to BRP Connect when the phone is plugged into the frunk. The reply we received was that BRP complaint resolution team would follow up with us on this matter. To date we have heard nothing back.

    As with the previous alternator issue where the alternator had to be replaced after a few weeks, we have now also been told that this current problem is the first they have heard of worldwide with 2019 RT's. So it looks like according to BRP that our brand new 2019 Spyder RT is the only one to have both these issues straight out of the factory. To us this is totally unacceptable when we have paid so much for a brand new RT. Our dealer is doing his best for us but this is just not acceptable from BRP - where is the quality control/customer service?

    It looks like once again we will have to get our new Spyder back to the dealer (a four hour drive away) to have it looked at yet again for this latest issue. We are beyond frustrated !!

  12. #12
    Active Member
    Join Date
    May 2019
    Location
    New Mexico
    Posts
    140
    Spyder Garage
    0

    Default

    I can say that I had an issue with my 2018 dropping BRP Connect connection to my Samsung S7. Traced it to the cheap USB cable I bought from Best Buy. It seems that *that* cable would intermittently lose connection - I determined that wear due to flexure of the cable near the mini connector would cause it to drop connection. Replaced USB cable with a known good one and problem was solved.

  13. #13
    Active Member
    Join Date
    Apr 2013
    Location
    Republic of Ireland
    Posts
    62
    Spyder Garage
    0

    Default

    Hi SuperG, wish it would be that easy for us but we’re using iPhone 8 Plus and have tried different genuine apple iPhone cables without success. It looks to be either an issue with the BRP USB cable/connection or BRP Connect or something else!

  14. #14
    Member
    Join Date
    Jun 2019
    Location
    at my home in Union County NJ
    Posts
    2
    Spyder Garage
    1

    Default

    I picked up my 2019 Spyder F3 Limited on July 1 and BRP Connect has not worked at all. I have a iPhone XS Max that's up to date, BRP Connect is up to date also, apple's mapping program only show's where I am, cant do anything other then zoom in or out. The other mapping apps say I need to buy them first, the free versions don't seem to work and I shouldn't have to pay for something that is advertised as coming with the bike. ITunes only lets me select something to play, when it connects, volume doesn't work, all the joy stick does is change the song. I need to get out off BRP connect to raise or lower the volume, and then I cant skip tracks. Also the song playing isn't listed on the screen. To many issues to list. Seems like ride2gethigh has the only sane solution. Presently I just use my phone over the Bluetooth, which sucks considering how much we paid for the bike. I never thought I'd have this much trouble with my ride after I got rid of my Harley. Goes to show you that every bike manufacture has issues with their products. But BRP should be doing more then just give lip service.

  15. #15
    Very Active Member Flamewinger's Avatar
    Join Date
    Aug 2013
    Location
    SF Bay Area
    Posts
    1,211
    Spyder Garage
    1

    Default

    I was the first to get the new Spyder in California. I had to do what others did which was figure out how to work it. I have played with it and learned how to work it (thanks to others on here). I learned how to switch from one thing to another to make adjustments, and because of the practice I have come to enjoy it much better than using the old Garmin. Much easier to use with the joystick compared to trying to use the phone with fingerless gloves. Creating routes in Sygic or Genius Maps is way easier and much quicker than on a Garmin because of a much faster processor. I like Sygic better because it is easier to see compared to Genius which doesn't have large enough text.

    With anything new you have to learn how to use it and once you've done that, it's a breeze. I don't complain and resort to using old Tech, I take the time to figure it out and get the best I can out it whatever I try to do.

    Susie - 2018 RT-Limited with 8400 miles so far . . .
    '13 Spyder ST-L with 21k miles
    '04 GL1800 with 91k miles
    '97 GL1500 with 87k miles
    '95 GL1500 with 102k miles
    '89 GL1500 with 96k miles
    '83 GL1100 with 117k miles
    [/COLOR]'81 Honda Silverwing with 36k miles
    '79 Kaw 400LTD with 26k miles
    GWRRA - 39 yrs - Life Member
    AMA - 39 yrs
    Just remember, if common sense is so common, why do few people have it?

  16. #16
    Active Member
    Join Date
    Apr 2013
    Location
    Republic of Ireland
    Posts
    62
    Spyder Garage
    0

    Default

    Hi guys, I completely understand your frustration corsonsr - to have paid so much money for a product that is not supported by the manufacturer is disgraceful. In my opinion the very few pages of the 2019 manual that refers to the operation of BRP Connect is not fit for purpose - as for the video tutorials they are vague and do not go into the appropriate amount of detail they should.
    I also agree with you Flamewinger that we should give BRP Connect a chance which is what I have done and I have learned how to operate it through the very helpful people on this forum including yourself. The help and tips I received from this forum have been terrific - but this is something that should have been forthcoming from BRP who launched this new product.
    In my case my dealer tells me that I apparently have issues with either the usb cable in the frunk or the dash cluster - which BRP say haven’t been seen before in 2019 models in relation to BRP Connect and to date I still have had no reply from BRP !!
    My dealer is still waiting on these parts from BRP for several weeks and to date he still hasn’t received them - what a joke!!!

  17. #17
    Active Member
    Join Date
    Jun 2019
    Location
    Canuckistan
    Posts
    82
    Spyder Garage
    0

    Default

    In times such as these, I find solace in a little humour....



    Lastly - Please do NOT blame the REST of Canada for BRP's fumbles

    Cheers
    E

  18. #18
    Member
    Join Date
    Aug 2018
    Location
    Maryland
    Posts
    1
    Spyder Garage
    1

    Default

    I’m sorry to be so late in replying to this post—new retirement and a house move have prevented us from enjoying our new 2018 RTLs of late, and I had not kept up with Spiderlovers.

    I had experienced the same disconnect problem with BRP connect, and I found that my iPhone had timed out. I normally have the screen lock out set for 2 minutes; I ended up setting the timeout to “Never”, and I haven’t had an issue since (except when I forgot to do it before a ride).

    Perhaps that can be the cause of your ills.

    Good luck!

  19. #19
    Very Active Member Flamewinger's Avatar
    Join Date
    Aug 2013
    Location
    SF Bay Area
    Posts
    1,211
    Spyder Garage
    1

    Default

    I found that rebooting the phone once in a while prevents this and other problems. Shutting it off and waiting a few minutes then turning it on and no more problems. I paid a lot for this bike and I'm not going to let it get the better of me! I have played with it and love it as I have learned how it works and have no problems. New technology is going to be challenging and if you don't want to take the challenge then don't buy it!

    I just did a short ride and used Rever to track my route and it now makes a video of the terrain with the route. Really cool.


    Susie - 2018 RT-Limited with 8400 miles so far . . .
    '13 Spyder ST-L with 21k miles
    '04 GL1800 with 91k miles
    '97 GL1500 with 87k miles
    '95 GL1500 with 102k miles
    '89 GL1500 with 96k miles
    '83 GL1100 with 117k miles
    [/COLOR]'81 Honda Silverwing with 36k miles
    '79 Kaw 400LTD with 26k miles
    GWRRA - 39 yrs - Life Member
    AMA - 39 yrs
    Just remember, if common sense is so common, why do few people have it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •