Results 1 to 3 of 3
  1. #1
    Active Member OlJim's Avatar
    Join Date
    May 2015
    Location
    NE Oklahoma
    Posts
    135
    Spyder Garage
    0

    Default Trailer light harness

    I found a really good deal on a Can Am trailer hitch so I bought it thinking i might someday buy a trailer. Someday has arrived and I can not for the life of me get the trailer lights to work. I purchased the Show Chrome harness which is 5 wire out. The trailer has a 4 wire flat so I purchased a 5 wire to 4 wire adapter and the only thing that works on the trailer is the tail lights, no brake or turn. What have I missed. Did I get a bad adapter or is there something else that could be wrong? 2011 RT SM5

  2. #2
    Very Active Member Bfromla's Avatar
    Join Date
    Aug 2014
    Location
    Bossier loUiSiAna
    Posts
    4,010
    Spyder Garage
    1

    Default

    Talk to Show Chrome they should have a simple solution for ya

    2013 STL SE5 BLACK CURRANT
    SpyderPop's: LED bumpskid
    SmoothSpyder: dualmode back rest
    T r * * LED:foam grip covers, Tricrings, FenderZ &brake light strips,
    wide vue mirrors
    Lid lox
    sawblade mowhalk fender accents
    minispyder dash toy
    Pakitrack
    FLO (Frunk Lid Organizer)
    BRP trailer hitch & 622 trailer (with its own list: Spyderpops Lighted Rear Bumpskid, LineX protection on sides, led trim lighting amber front& red rear, stand& tongue handle)THX Cruzr Joe!
    (pics in album)

  3. #3
    Active Member OlJim's Avatar
    Join Date
    May 2015
    Location
    NE Oklahoma
    Posts
    135
    Spyder Garage
    0

    Default

    Well apparently it was a bad converter. Reolaced the original converter and everything works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •