Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Jan 2014
    Location
    North-east Oregon
    Posts
    15
    Spyder Garage
    0

    Default Cleaning PTT switch

    My PTT switch seems to be having problems. My riding companions say it is cutting out or breakin up. It seems to work better if I use a "death grip" and hold.

    I know that some Goldwing riders have a similar problem and can get into the switch with contact cleaner. Has anyone done this on the Spyder and if so, could you give me some pointers?

    My Spyder is a 2014 RT-S and I have the BRP CB.

    Thanks in advance. Dicky Richard

  2. #2
    Very Active Member billybovine's Avatar
    Join Date
    Jul 2011
    Location
    Mitchell, Ontario, Canada
    Posts
    5,650
    Spyder Garage
    0

    Default

    The PTT switch is encased in silicone rubber and completely sealed. So contact cleaner will not fix anything. The normal fix would be to replace the whole left handlebar switch assembly. That's a pricey option. Maybe it's just got dirt in it. Remnants of suicidal bugs. Give it a good spray with a light lube. WD40, silicone spray or whatever. Get as much inside as possible. Remember everything is sealed. So it won't hurt anything. The problem with contact cleaner is it works too well and removes all lubrication. The plastic parts don't slide against each other any more.

    2018 F3 LIMITED

  3. #3
    Very Active Member IdahoMtnSpyder's Avatar
    Join Date
    Jan 2014
    Location
    Idaho
    Posts
    6,409
    Spyder Garage
    1

    Default

    Quote Originally Posted by DickyRichard View Post
    My PTT switch seems to be having problems. My riding companions say it is cutting out or breakin up. It seems to work better if I use a "death grip" and hold.

    I know that some Goldwing riders have a similar problem and can get into the switch with contact cleaner. Has anyone done this on the Spyder and if so, could you give me some pointers?

    My Spyder is a 2014 RT-S and I have the BRP CB.

    Thanks in advance. Dicky Richard
    I've been having the same problem with my 2014 RTS & CB. I need to figure out what's causing the breaking up so maybe it's the same thing you're experiencing. On the other hand, I was leaning toward checking out the continuity of the antenna wire and the antenna itself, or maybe a ground connection of the antenna. Or maybe the antenna has loosened in the mounting block. Anyway, don't just assume it's the PTT. There could be other causes also.

    One reason I'm skeptical about the PTT being the problem is the CB doesn't respond instantly to PTT button pushes so I'm not sure that a quick make & break in the PTT switch will cause the signal to break up. Also check out your helmet cord. It may have a broken wire in it. Mine did last fall.

    2014 Copper RTS

    Tri-Axis bars, CB, BajaRon sway bar & shock adjusters, SpyderPop's Bumpskid, NBV peg brackets, LED headlights and modulator, Wolo trumpet air horns, trailer hitch, custom trailer harness, high mount turn signals, Custom Dynamics brake light, LED turn signal lights on mirrors, LED strip light for a dash light, garage door opener, LED lights in frunk, trunk, and saddlebags, RAM mounts and cradles for tablet (for GPS) and phone (for music), and Smooth Spyder belt tensioner.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •