Results 1 to 11 of 11
  1. #1
    Active Member solidgranite's Avatar
    Join Date
    Aug 2016
    Location
    North Carolina
    Posts
    126
    Spyder Garage
    0

    Question How Much to Replace ECM on 2012 RT SE5?

    I may need to have the ECM replaced on my 2012 RT SE5. Anybody got a rough estimate of what the Can-Am dealer will charge for this? I bought the bike used, so have no idea of whether or not the ECM has been updated or flashed (50,000+ miles), but its giving me headaches now...check engine light, ABS light, and others come on right after starting. Sometimes they go away in a minute. Sometimes they don't. When I bring it to the dealer, they'll probably recommend replacing the ECM, so I'm wondering how much it will cost.

  2. #2
    Very Active Member BLUEKNIGHT911's Avatar
    Join Date
    Aug 2011
    Location
    Central VERMONT
    Posts
    12,294
    Spyder Garage
    0

    Default

    Quote Originally Posted by solidgranite View Post
    I may need to have the ECM replaced on my 2012 RT SE5. Anybody got a rough estimate of what the Can-Am dealer will charge for this? I bought the bike used, so have no idea of whether or not the ECM has been updated or flashed (50,000+ miles), but its giving me headaches now...check engine light, ABS light, and others come on right after starting. Sometimes they go away in a minute. Sometimes they don't. When I bring it to the dealer, they'll probably recommend replacing the ECM, so I'm wondering how much it will cost.
    look here ...cheapcycleparts.com …………. I think my friend paid $1200.00=/- ……….. If you go to a dealer DO NOT SAY - I think it's my ECM .... they are not impressed how smart you are, they won't care ….. But they are very,very likely to start by re-placing it …. ALL on your cost ……….. good luck …. Mike

  3. #3
    Very Active Member Chupaca's Avatar
    Join Date
    Oct 2012
    Location
    San Diego, CA.
    Posts
    30,333
    Spyder Garage
    1

    Default Here you go...

    The ECM at cheapcycleparts.com runs $534.00 Depending on the shop rates it looks to be Flat rated at 2.0 hours. have them determine the problem and get your own parts if it is your dime. Cheapcycleparts are OEM parts...
    Gene and Ilana De Laney
    Mt. Helix, California

    ​2012 RS sm5

  4. #4
    Active Member
    Join Date
    Sep 2016
    Location
    Chillicothe, Oh.
    Posts
    387
    Spyder Garage
    1

    Default

    The bike is seven years old. I would clean and use dielectric grease on the electrical connections before I took it in for an expensive item that may not need replaced. Loose and/or dirty connectors will cause all sorts of wonky stuff to happen.

  5. #5
    Very Active Member IdahoMtnSpyder's Avatar
    Join Date
    Jan 2014
    Location
    Idaho
    Posts
    6,259
    Spyder Garage
    1

    Default

    Quote Originally Posted by Navydad View Post
    The bike is seven years old. I would clean and use dielectric grease on the electrical connections before I took it in for an expensive item that may not need replaced. Loose and/or dirty connectors will cause all sorts of wonky stuff to happen.
    Have you had it to the dealer yet? If not, take it there and have them check it out. They should be able to get a good diagnosis using BUDS. As far as I know no one here has reported an ECM going bad. Very doubtful that is your problem.

    2014 Copper RTS

    Tri-Axis bars, CB, BajaRon sway bar & shock adjusters, SpyderPop's Bumpskid, NBV peg brackets, LED headlights and modulator, Wolo trumpet air horns, trailer hitch, custom trailer harness, high mount turn signals, Custom Dynamics brake light, LED turn signal lights on mirrors, LED strip light for a dash light, garage door opener, LED lights in frunk, trunk, and saddlebags, RAM mounts and cradles for tablet (for GPS) and phone (for music), and Smooth Spyder belt tensioner.

  6. #6
    Very Active Member BLUEKNIGHT911's Avatar
    Join Date
    Aug 2011
    Location
    Central VERMONT
    Posts
    12,294
    Spyder Garage
    0

    Default

    Quote Originally Posted by IdahoMtnSpyder View Post
    Have you had it to the dealer yet? If not, take it there and have them check it out. They should be able to get a good diagnosis using BUDS. As far as I know no one here has reported an ECM going bad. Very doubtful that is your problem.
    To clarify about my friends ECM failure ….. It was the connecting plug that failed ….somehow a few of the pins corroded and broke …. the connection leaked ….check your pins ….. Mike

  7. #7
    Active Member solidgranite's Avatar
    Join Date
    Aug 2016
    Location
    North Carolina
    Posts
    126
    Spyder Garage
    0

    Default

    Quote Originally Posted by BLUEKNIGHT911 View Post
    look here ...cheapcycleparts.com …………. I think my friend paid $1200.00=/- ……….. If you go to a dealer DO NOT SAY - I think it's my ECM .... they are not impressed how smart you are, they won't care ….. But they are very,very likely to start by re-placing it …. ALL on your cost ……….. good luck …. Mike
    Good advice...thanks. I'll have them do an electric diagnosis or run BUDS and see what they find. I'd rather pay for them tightening a loose wire than a whole new ECM.. :-)

  8. #8
    Active Member solidgranite's Avatar
    Join Date
    Aug 2016
    Location
    North Carolina
    Posts
    126
    Spyder Garage
    0

    Default

    Quote Originally Posted by IdahoMtnSpyder View Post
    Have you had it to the dealer yet? If not, take it there and have them check it out. They should be able to get a good diagnosis using BUDS. As far as I know no one here has reported an ECM going bad. Very doubtful that is your problem.
    Yup, that's exactly what I'll do. Hopefully its a loose wire or something simple like that. Don't want to pay for a new ECM if I don't absolutely need one. :-)

  9. #9
    Active Member solidgranite's Avatar
    Join Date
    Aug 2016
    Location
    North Carolina
    Posts
    126
    Spyder Garage
    0

    Default

    Quote Originally Posted by Chupaca View Post
    The ECM at cheapcycleparts.com runs $534.00 Depending on the shop rates it looks to be Flat rated at 2.0 hours. have them determine the problem and get your own parts if it is your dime. Cheapcycleparts are OEM parts...
    I don't know if my Can Am dealer will aloow me to supply my own parts, but if it turns out that I need to replace the ECM, I'll certainly ask them! Every penny saved is another mile I can ride...LOL

  10. #10
    Active Member solidgranite's Avatar
    Join Date
    Aug 2016
    Location
    North Carolina
    Posts
    126
    Spyder Garage
    0

    Default

    Quote Originally Posted by BLUEKNIGHT911 View Post
    To clarify about my friends ECM failure ….. It was the connecting plug that failed ….somehow a few of the pins corroded and broke …. the connection leaked ….check your pins ….. Mike
    I'll try to figure out where the pins are located, and check them out. I didn't see any loose wires, but I only looked at "surface stuff" that was visible without taking the tupperware off. Thanks!

  11. #11
    Very Active Member Chupaca's Avatar
    Join Date
    Oct 2012
    Location
    San Diego, CA.
    Posts
    30,333
    Spyder Garage
    1

    Default

    Quote Originally Posted by solidgranite View Post
    I don't know if my Can Am dealer will aloow me to supply my own parts, but if it turns out that I need to replace the ECM, I'll certainly ask them! Every penny saved is another mile I can ride...LOL
    All parts from cheapcycleparts.com are in BRP packaging with part numbers so dealer should have no problem. But check prices anyway....
    Gene and Ilana De Laney
    Mt. Helix, California

    ​2012 RS sm5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •