Results 1 to 6 of 6
  1. #1
    Active Member Haze's Avatar
    Join Date
    Oct 2015
    Location
    Carson CIty, Nevada
    Posts
    411
    Spyder Garage
    0

    Default ST Cruise Control Difficult to Set

    This is a new problem. The bike has performed flawlessly for the previous 16K miles.
    2013 STS. SM5.
    In the past few rydes the cruise control has been acting strange (erratic).
    It will turn "on" with the right hand grip slide switch.
    When I push the slider down to set the speed, the indicator in the instrument cluster,
    briefly flashes green "Set" and immediately reverts back to showing "On" in black and white.
    The cruise doesn't turn off it just refuses to set. After a few miles of fiddling, turning off/on and
    reengaging the system SOMETIMES works.
    I lift the brake pedal with my toe and push outward on the clutch lever with my gloved hand. (ATGATT)

    I'm thinking a finicky sensor.

    Now my question...How many and where are the cruise control sensors located.
    I know the brake switch can act up and affects the cruise setting.
    Possibly a sensor in the clutch system??
    Are there any other switches and sensors that I should look at??
    David C
    2013 ST-S Circuit Yellow

  2. #2
    Very Active Member JayBros's Avatar
    Join Date
    Jul 2014
    Location
    Mint Hill, NC
    Posts
    3,260
    Spyder Garage
    0

    Default

    My uneducated WAG is the switch itself. If you press down and get the "Set" notification that then changes back to "On" smells like the down function is on the fritz.
    Artillery lends dignity to what would
    otherwise be a vulgar brawl.
    ******************************
    Cognac 2014 RT-S

  3. #3
    Very Active Member billybovine's Avatar
    Join Date
    Jul 2011
    Location
    Mitchell, Ontario, Canada
    Posts
    5,439
    Spyder Garage
    0

    Default

    I will guess the brake lights are staying on. Bad or dirty brake light switch. Not an uncommon problem for 2013 ST models. You need to get it fix soon. If you don't it can drain the battery while parked if you do not notice the lights still on. Personal experience here.
    Last edited by billybovine; 09-28-2018 at 06:28 PM.

    2018 F3 LIMITED

  4. #4
    Active Member ssmcclub's Avatar
    Join Date
    Apr 2013
    Location
    massapequa ny 11758
    Posts
    229
    Spyder Garage
    0

    Default

    Had same problem just tap the brake peddle and then set cruise control it should work
    richie spyder

  5. #5
    Active Member dginoregon's Avatar
    Join Date
    Sep 2013
    Location
    Grants Pass, Oregon
    Posts
    78
    Spyder Garage
    1

    Default

    Had similar problem, is a known problem with the brake peddle lever. Took it in and they replaced with a new designed lever, fixed the problem.

  6. #6
    Active Member Haze's Avatar
    Join Date
    Oct 2015
    Location
    Carson CIty, Nevada
    Posts
    411
    Spyder Garage
    0

    Default Cruise control

    To all, Thanks for the responses.
    I will be checking and cleaning the brake light switch
    and brake linkage tomorrow.
    David C
    2013 ST-S Circuit Yellow

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •