Results 1 to 7 of 7

Thread: Engine Light on

  1. #1
    Member
    Join Date
    Jun 2017
    Location
    Missouri
    Posts
    18
    Spyder Garage
    0

    Default Engine Light on

    I was on a ride the other day and the engine light came on. My spyder is a 2014 ST Limited. It wasnít running hot, checked oil and it was between full and Add. I tried to check to see if there was any codes by holding mode and set along with the signal cancel button but all it does is come up with a blank screen. I do have a power programmer on the bike. Itís been running fine but I did fill up with 88 octane gas. Does anyone have any suggestions on what to check or do next. Closest dealer is about a hour away. The check engine light comes on and stayed on but doesnít flash and the bike never went into limp mode. Ideas please

  2. #2
    Very Active Member Chupaca's Avatar
    Join Date
    Oct 2012
    Location
    San Diego, CA.
    Posts
    30,584
    Spyder Garage
    1

    Default Let's see...

    First of all the check engine light will come for any reason including non engine issues. The code will tell you why. Now not having a code you should start by starting the ST then shut her off remove the key go inside and give it 30 to 45 minutes to reset the computers. Then start up normally and see if the check engine light is out then Ryde as usual and see if it comes back on. If it doesn't could have been a glitch if it does shut the engine off using the kill switch leaving the key on and check for codes. Not sure what a power programmer is unless it is a fuel mixture controller which can cause a rich or lean mixture problem. Let us know what you find out...
    Gene and Ilana De Laney
    Mt. Helix, California

    ​2012 RS sm5

  3. #3
    Very Active Member Warlock's Avatar
    Join Date
    Oct 2011
    Location
    Magnolia, Ms
    Posts
    831
    Spyder Garage
    0

    Default

    Quote Originally Posted by Jjrk3 View Post
    I was on a ride the other day and the engine light came on. My spyder is a 2014 ST Limited. It wasnít running hot, checked oil and it was between full and Add. I tried to check to see if there was any codes by holding mode and set along with the signal cancel button but all it does is come up with a blank screen. I do have a power programmer on the bike. Itís been running fine but I did fill up with 88 octane gas. Does anyone have any suggestions on what to check or do next. Closest dealer is about a hour away. The check engine light comes on and stayed on but doesnít flash and the bike never went into limp mode. Ideas please
    I would check and make sure all the relays are plugged in good

  4. #4
    Member
    Join Date
    Jun 2017
    Location
    Missouri
    Posts
    18
    Spyder Garage
    0

    Default

    Took the Spyder out for a ride today and got back and checked the codes and it showed P1171 and P0130. From what I looked up it is too lean and a O2 sensor. I have a power commander on it so that may be what is causing it. How do I clear the codes to see if it stays active? Bike runs great still.

  5. #5
    Very Active Member Chupaca's Avatar
    Join Date
    Oct 2012
    Location
    San Diego, CA.
    Posts
    30,584
    Spyder Garage
    1

    Default Well....

    Dealer can erase the codes otherwise they stay stored in the computer. I have seen post with some button pushing sequence they say will erase the codes. Thing is if no warning lights are on you don't have to worry about them. Some controlers used their own O2 sensor some used the exsiisting one. if it was added because of a change in the exhaust you may have leaks be it from the gaskets the vaccum lines or falty sensor...
    Gene and Ilana De Laney
    Mt. Helix, California

    ​2012 RS sm5

  6. #6
    SpyderLovers Sponsor SpyderAnn01's Avatar
    Join Date
    Jun 2010
    Location
    Las Vegas
    Posts
    12,558
    Spyder Garage
    0

    Default

    If you remove the power commander and the check engine light stays off you donít have to worry about the code. It will have changed from Active to Occurred and it is stored that way until cleared with BUDS

    2017 F3T-SM6 Squared Away Mirror Wedgies & Alignment
    2014 RTS-SM6 123,600 miles Sold 11/2017
    2014 RTL-SE6 8,600 miles
    2011 RTS-SM5 5,000 miles
    2013 RTS-SM5 burned up with 13,200 miles in 13 weeks
    2010 RTS-SM5 59,148 miles
    2010 RT- 622

  7. #7
    Active Member jtonga's Avatar
    Join Date
    Jun 2018
    Location
    Rhode Island
    Posts
    35
    Spyder Garage
    0

    Default

    Quote Originally Posted by Jjrk3 View Post
    Took the Spyder out for a ride today and got back and checked the codes and it showed P1171 and P0130. From what I looked up it is too lean and a O2 sensor. I have a power commander on it so that may be what is causing it. How do I clear the codes to see if it stays active? Bike runs great still.
    Just wondering how you made out with the P1171 and P0130 codes. Did you have to fix or adjust anything to clear those codes?

    Thanks, Joe
    2014 Spyder RSS SE5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •