Results 1 to 2 of 2
  1. #1
    Active Member OkieDoc's Avatar
    Join Date
    Oct 2013
    Location
    Oklahoma
    Posts
    40
    Spyder Garage
    0

    Default F3-T Poor Radio Reception

    I've always had poor reception on the radio on my 2017 F3-T. When I got the bike I had read several posts complaining of poor reception and just assumed it was the nature of the beast. Today while doing some work to her I noticed this electrical ring terminal not connected to anything and kind of just stuffed down next to the frame rail by the antenna. (I pulled it up a bit to take the picture) My curiosity took a closer look, tracing it under a bundle of wires I realize it is the antenna lead.
    I go online and check a parts finche and it is supposed to be under the antenna mast where it screws down. The rubber cover at the base of the antenna just pulls off and the antenna unscrews from the mount. I put it all back together as the parts finche showed and now I receive every radio station in the area.
    I don't know if the was an assembly line or dealer prep error, but it is an easy fix. Remove your rear seat and two push pins and your back cover will come off. If you are experiencing poor radio reception this is something to check.

    25289553_1607122752658311_111127373360858691_n.jpg
    2017 F3-T SM6, Intense Pearl Red, SpyderPops Run/Turn/Brake, Baja Ron Sway Bar and Skid Plate, 21 Inch Tinted F4, Signature Light, ******* LED Headlights Yokohoma S-Drive, Ultimate Tall Boy.

  2. #2
    Member
    Join Date
    Mar 2019
    Location
    Fort Worth, Tx
    Posts
    4
    Spyder Garage
    1

    Default

    Quote Originally Posted by OkieDoc View Post
    I've always had poor reception on the radio on my 2017 F3-T. When I got the bike I had read several posts complaining of poor reception and just assumed it was the nature of the beast. Today while doing some work to her I noticed this electrical ring terminal not connected to anything and kind of just stuffed down next to the frame rail by the antenna. (I pulled it up a bit to take the picture) My curiosity took a closer look, tracing it under a bundle of wires I realize it is the antenna lead.
    I go online and check a parts finche and it is supposed to be under the antenna mast where it screws down. The rubber cover at the base of the antenna just pulls off and the antenna unscrews from the mount. I put it all back together as the parts finche showed and now I receive every radio station in the area.
    I don't know if the was an assembly line or dealer prep error, but it is an easy fix. Remove your rear seat and two push pins and your back cover will come off. If you are experiencing poor radio reception this is something to check.

    25289553_1607122752658311_111127373360858691_n.jpg
    Thank you very much. I've had a 2018 F3-T for a month now and I also had extremely poor radio reception. I live in the middle of DFW and I could only get 1 radio station. After seeing this thread, I checked it and mine was the same way. I attached the antenna lead wire to the antenna and now I get every station that I should. The picture you posted pretty much is exactly what I was seeing when investigating.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •