Results 1 to 10 of 10
  1. #1
    Active Member OkieDoc's Avatar
    Join Date
    Oct 2013
    Location
    Oklahoma
    Posts
    40
    Spyder Garage
    0

    Default F3-T Poor Radio Reception

    I've always had poor reception on the radio on my 2017 F3-T. When I got the bike I had read several posts complaining of poor reception and just assumed it was the nature of the beast. Today while doing some work to her I noticed this electrical ring terminal not connected to anything and kind of just stuffed down next to the frame rail by the antenna. (I pulled it up a bit to take the picture) My curiosity took a closer look, tracing it under a bundle of wires I realize it is the antenna lead.
    I go online and check a parts finche and it is supposed to be under the antenna mast where it screws down. The rubber cover at the base of the antenna just pulls off and the antenna unscrews from the mount. I put it all back together as the parts finche showed and now I receive every radio station in the area.
    I don't know if the was an assembly line or dealer prep error, but it is an easy fix. Remove your rear seat and two push pins and your back cover will come off. If you are experiencing poor radio reception this is something to check.

    25289553_1607122752658311_111127373360858691_n.jpg
    2017 F3-T SM6, Intense Pearl Red, SpyderPops Run/Turn/Brake, Baja Ron Sway Bar and Skid Plate, 21 Inch Tinted F4, Signature Light, Tricled LED Headlights Yokohoma S-Drive, Ultimate Tall Boy.

  2. #2
    Member
    Join Date
    Mar 2019
    Location
    Fort Worth, Tx
    Posts
    4
    Spyder Garage
    1

    Default

    Quote Originally Posted by OkieDoc View Post
    I've always had poor reception on the radio on my 2017 F3-T. When I got the bike I had read several posts complaining of poor reception and just assumed it was the nature of the beast. Today while doing some work to her I noticed this electrical ring terminal not connected to anything and kind of just stuffed down next to the frame rail by the antenna. (I pulled it up a bit to take the picture) My curiosity took a closer look, tracing it under a bundle of wires I realize it is the antenna lead.
    I go online and check a parts finche and it is supposed to be under the antenna mast where it screws down. The rubber cover at the base of the antenna just pulls off and the antenna unscrews from the mount. I put it all back together as the parts finche showed and now I receive every radio station in the area.
    I don't know if the was an assembly line or dealer prep error, but it is an easy fix. Remove your rear seat and two push pins and your back cover will come off. If you are experiencing poor radio reception this is something to check.

    25289553_1607122752658311_111127373360858691_n.jpg
    Thank you very much. I've had a 2018 F3-T for a month now and I also had extremely poor radio reception. I live in the middle of DFW and I could only get 1 radio station. After seeing this thread, I checked it and mine was the same way. I attached the antenna lead wire to the antenna and now I get every station that I should. The picture you posted pretty much is exactly what I was seeing when investigating.

  3. #3
    Active Member
    Join Date
    Nov 2015
    Location
    Cypress
    Posts
    131
    Spyder Garage
    1

    Default

    I took your advice and went looking for the antenna lead you described. What I found was not what I expected. In my case the lead was secured in place but what else found was a surpsise. Note the picture attached. Yes, it appears to be a cozy mouse's nest...
    Doesn't appear to have a current resident as it seems the bike was sold to me while Mr. Mouse was out foraging and when he returned the bike was on it's way to me.
    Having never had that panel off in the time I owned the bike I never looked under there. I did replace the antenna while in there and used Dielectric grease on the connections. Will check out the reception later today.
    Thanks for the tip....
    Buckskin




    Quote Originally Posted by OkieDoc View Post
    I've always had poor reception on the radio on my 2017 F3-T. When I got the bike I had read several posts complaining of poor reception and just assumed it was the nature of the beast. Today while doing some work to her I noticed this electrical ring terminal not connected to anything and kind of just stuffed down next to the frame rail by the antenna. (I pulled it up a bit to take the picture) My curiosity took a closer look, tracing it under a bundle of wires I realize it is the antenna lead.
    I go online and check a parts finche and it is supposed to be under the antenna mast where it screws down. The rubber cover at the base of the antenna just pulls off and the antenna unscrews from the mount. I put it all back together as the parts finche showed and now I receive every radio station in the area.
    I don't know if the was an assembly line or dealer prep error, but it is an easy fix. Remove your rear seat and two push pins and your back cover will come off. If you are experiencing poor radio reception this is something to check.

    25289553_1607122752658311_111127373360858691_n.jpg
    Attached Images Attached Images

  4. #4
    Very Active Member
    Join Date
    Apr 2017
    Location
    North Central Florida
    Posts
    2,492
    Spyder Garage
    0

    Default

    Quote Originally Posted by Buckskin View Post
    I did replace the antenna while in there and used Dielectric grease on the connections.
    Dielectric grease is an insulator.
    It is NOT intended to be used INSIDE of a connection like that.

  5. #5
    Member
    Join Date
    May 2019
    Location
    Indianola,iowa
    Posts
    7
    Spyder Garage
    0

    Default

    I want to thank you for this tip! I bought a new 2018 f3t in February and have been mostly listening to my phone music because the radio sucked! I saw yesterday that there was nothing attached to the antenna and wondered how it got a signal at all? Today I did as you said and after cleaning a (rodent)? Nest that was under the rear cowl I found the wire and attached it to the antenna base. I now get all the channels my car gets! Thank you, thank you! It says radio right there! I wonder if it’s a factory or dealer mistake there?

  6. #6
    Member Wildass's Avatar
    Join Date
    Mar 2019
    Location
    VAN VLECK TEXAS
    Posts
    22
    Spyder Garage
    0

    Default

    So I went out to my 2018 F3T and sure enough the little wire was NOT connected to the antenna. They put so much lock tight blue I destroyed the antenna. To my luck my son had changed the one on his 2018 road glide so I put it on taller but the radio now works yea!

  7. #7
    Member
    Join Date
    May 2019
    Location
    Indianola,iowa
    Posts
    7
    Spyder Garage
    0

    Default

    I asked my dealer what they do as dealer set up. Mostly wheels etc. the radio lead should be attached by the factory.

  8. #8
    Member
    Join Date
    Aug 2018
    Location
    Long Island NY
    Posts
    13
    Spyder Garage
    0

    Default

    I have the same problem on my 2017 F3L. does anyone know if this is common on the limited?

  9. #9
    Very Active Member BLUEKNIGHT911's Avatar
    Join Date
    Aug 2011
    Location
    Central VERMONT
    Posts
    12,984
    Spyder Garage
    0

    Default

    Quote Originally Posted by stevet View Post
    I have the same problem on my 2017 F3L. does anyone know if this is common on the limited?
    It doesn't matter what type Spyder you have or year …… BRP has had problems with every radio antennae connection … they use way to much LokTite and this tuff is an Insulator …. So clean it all off ( inside and outside threads ) and use a Star washer to keep it secure …… this has improved the reception for a lot of folks …… However it also depends on how strong a signal you have...… I completely cured my issues ( after cleaning ) by switching to a Bosche manual retractable auto Antennae...… I live in Vt. which is mostly mountainous all over …… I now get pretty good reception almost as good as my Toyt ……. good luck …. Mike

  10. #10
    Active Member
    Join Date
    Apr 2016
    Location
    St. Charles IL
    Posts
    116
    Spyder Garage
    0

    Default

    Holy moley!
    Bill W

    2019 F3 LTD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •