Thanks Thanks:  174
Likes Likes:  259
Page 14 of 14 FirstFirst ... 41011121314
Results 326 to 339 of 339

Thread: MAGIC MIRRORS

  1. #326
    Very Active Member SPYD1's Avatar
    Join Date
    Mar 2011
    Location
    Hudsonville, MI
    Posts
    1,859

    Default

    Still waiting for mine. This is crazy slow.

  2. #327
    Active Member
    Join Date
    Jun 2016
    Location
    Phoenix
    Posts
    213

    Default Easy install

    Only thing that was hard for me was getting the clip screws on the mirror itself out. Felt as though they were glued, didn't want to strip the heads. Might be nice to know what size they are just in case someone does strip them.The product is 100% quality product. I am satisfied.

  3. #328
    Very Active Member irvin48's Avatar
    Join Date
    May 2016
    Location
    mt morris il
    Posts
    788

    Default

    doc has a install video on his site. got mine on this morn. another happy customer !
    --irv toms
    2015 rts-white pearl- mods- '16 F3 fat 6 chrome wheels,
    and some little stuff. setback utopia backrest, baja ron
    sway bar, oem adj. air deflectors, marlin gps compass,
    lamonster fbb foot pegs[modified brackets], doc's
    vibration damper, rock guard, and side case stiffener kit,
    7 jurock w/shield. brp comfort seat. led h/ls, fomozas and
    altimax, magic mirror mts, and tricled wide mirrors.
    [joyce & irvin toms]

  4. #329
    Very Active Member vided's Avatar
    Join Date
    Jun 2014
    Location
    Putnam county,ny
    Posts
    4,424

    Default

    WOWIE, what a easy install, 45 minutes,
    and not 1 bad word.
    [IMG]IMG]IMG]/IMG]
    2015 RTS SPCL RED/BLK, BAJARON SWAY BAR AND LINKS,SHORTY ANTENNA, DECALS GONE
    GARMIN 660LM, CAT GONE PIPE, MAGIC MIRRORS

    this posting has been vetted, scrubbed and endorsed by the
    committee for postings

  5. #330
    Eponymous Member Bob Denman's Avatar
    Join Date
    Sep 2010
    Location
    Grahamsville, NY
    Posts
    86,085

    Default

    Not even a single teeny-tiny one?


    2010 RT A&C ................................. 2014 RT Limited.
    (Both are gone, but not forgotten!)

  6. #331
    Active Member
    Join Date
    Jul 2013
    Location
    Marietta, GA
    Posts
    51

    Default

    Got mine today, shipped on 04-10
    will install tomorrow
    Thank you Russell

  7. #332
    SpyderLovers Sponsor merlot's Avatar
    Join Date
    May 2015
    Location
    Tasmania
    Posts
    84

    Default

    Quote Originally Posted by marty1096 View Post
    Only thing that was hard for me was getting the clip screws on the mirror itself out. Felt as though they were glued, didn't want to strip the heads. Might be nice to know what size they are just in case someone does strip them.The product is 100% quality product. I am satisfied.
    hi Marty
    sourcing these screws proved extremely difficult
    the easiest way to affix the new petals is with countersunk screws
    countersinking is relatively easy
    but I couldn't find plastic screws at 2.9dia with a thread pitch of 1.5mm
    so I had to go with the Oem screws....this meant a thicker petal and holes counter bored to suit

    wood screws go close but as we wanted the install to be fully reversible then it had to be with the original screws....counter boring is more time consuming but the end product is worth it
    some Oem screws have Phillips heads and others have torx heads also

    if you damage these screws then best to order new ones from brp
    russ

  8. #333
    Very Active Member cognaccruiser's Avatar
    Join Date
    Dec 2013
    Location
    South Okanagan, BC, Canada
    Posts
    618

    Default

    My magnets arrived yesterday, April 27th, safe and sound. Everything looks to be really substantial and good quality. Looking forward to getting them on.

    Gary
    States visited by Bike

  9. #334
    Active Member
    Join Date
    Jul 2013
    Location
    Marietta, GA
    Posts
    51

    Default

    installed.. very very nice

  10. #335
    Active Member
    Join Date
    Jan 2013
    Location
    San Diego area
    Posts
    160

    Default Magic mirrors

    Easiest farklel install ever and great product
    Loving the RYDE

  11. #336
    Very Active Member
    Join Date
    Dec 2013
    Location
    Aus, Sth Aust, Adelaide Hills
    Posts
    1,992

    Default

    Hey all, just got the heads up from mclava that he's resolved his 'High Temperature' problem!! I sent him a PM with a couple of things to look for re the Magic Mirrors; he tried 'em; & his temp gauge is now working properly again & his Spyder was running properly all along, no high temps at all!!

    Basically, it seems we have a very small percentage of Spyders that, upon installing the Magics, then show an abnormally high reading on the temp gauge. So far, the effected Spyders either have had the dash opened & wiring moved behind the temp gauge; or the polarity of the top RH magnet has somehow effected their temp gauge to make it read high! So far, 3 reports out of heaps of installed Magics kits (I haven't got the latest figure... yet?!) shows it's not a really common problem (except it's very significant for those it's happening to, of course! ) But at least we know how to fix it now!! (Thanks for getting back to us mclava! )

    The fixes are either: open the dash & make sure all the wiring in there is properly insulated & where it should be, clear of the inside of the mirror mounts; or possibly just simply flipping the top RH Magnet will do it!! All this cos it seems the magnet's polarity makes a difference to some temp gauges (very few?!); &/or the gauge wiring is getting too close to the magnet (possibly wiring with compromised insulation?!? I can see some more testing coming up!! ) can create this abnormally high reading in the temp gauge?!

    I'm sorry we didn't find this during testing, but now we know it's there, so here's a heads up just so you don't get worried by a sudden high reading temp gauge; & we do know how to fix it if you happen to be one of those with the issue!

  12. #337
    Very Active Member trikermutha's Avatar
    Join Date
    Sep 2014
    Location
    USA
    Posts
    2,111

    Default

    How about dess errors after installing the kit? Any issues that you know of?

  13. #338
    Very Active Member
    Join Date
    Dec 2013
    Location
    Aus, Sth Aust, Adelaide Hills
    Posts
    1,992

    Default

    We haven't been able to make anything else 'different' happen to anything.... those who were having the occasional DESS error still got them, those that hadn't yet had any still haven't, & everything we've tried to force an error hasn't produced diddly squat!! No impact even when a magnet was sat directly on top of the ignition & leaning on the key?!? We got more reaction to the weight of a full roll of magnets resting on the dash screen than we did from the magnetism/magnetic field! And that is really as expected - once the magnets are installed, they should have no impact on anything inboard or outboard of their mounted positions (since they'll be 'stuck' to a metal plate on either side) altho they may exhibit some small magnetic effect on sensitive materials that are brought into line with the curved sides of the magnetic cylinder, but that should be nothing much further than about 50-100mm or so away.

    And it's interesting that only a select few Spyders have had the temp gauge problems - I've found & tested Spyders with compromised wiring, purposefully compromised wiring, left plugs dangling, stripped insulation, hung the wires over the temp gauge, & pretty much plugged any/everything in the way of dodgy wiring directly onto the inside of the magnets, even left a magnet inside the dash, all without so much as a flicker in any gauge.... but obviously some temp gauges (& to my knowledge so far, NO fuel gauges!) just don't like being near the magnets, especially if the magnets are the 'wrong' way around (the 'flip the magnet' solution did work!) - & theoretically, once the magnets are attached to a metal sheet (as they will be once installed) there should be no 'stray magnetism' floating around on the other side of that sheet anyway (ie, inside the area behind the dash!)

    I have seen some documentation on magnetism & interference that adds to my suspicions that leaving the temp gauge wires or any added wiring (like LED mirror repeater wiring) free to move at all in there may be contributing (& hard to replicate) to the cause of these high temp gauge readings, but the issues still seem to be randomly(?) selective & apparently only occur on/to gauges that have some unique feature that we've not yet identified - & (so far) it's only been reported as happening to 3 gauges out of well over 500 kits....

    Ahh well, who was it who said something along the lines of, "Theoretically, that'll never happen in practice; but in practice, that's proven to be just a theory!"??

  14. #339
    SpyderLovers Sponsor merlot's Avatar
    Join Date
    May 2015
    Location
    Tasmania
    Posts
    84

    Default mailing times

    we have had a dismal time with the mailings to the united states and canada
    i have made more reversals for no shows than i care to think about
    so much so that we will be advising on the website that we can no longer ship,in single packs, to either of these destinations.....for some reason the UK has been exemplary..we shipped on monday and the buyer was fitting on saturday..scotland is good too

    i have been advised that no matter what the rate chosen,the problem is in the package ie it is a magnet and the scanner cant see it,so it will always fall into the abyss
    this has resulted in unacceptable wait times for buyers

    on the upside,the tracking number turns out to be international,so it will work for USPS and Canada Post tracking
    so if you are tracking your package on aust post and it stalls,then you can assume it has got to the states and now can be seen by usps...it wont get there any quicker but at least you can see it hasnt disappeared
    thanks russ

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •